audio element enables fall back content in parallel with real content

RESOLVED DUPLICATE of bug 487398

Status

()

--
major
RESOLVED DUPLICATE of bug 487398
9 years ago
9 years ago

People

(Reporter: toni.ruottu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090401 Ubuntu/9.04 (jaunty) Shiretoko/3.5b4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090401 Ubuntu/9.04 (jaunty) Shiretoko/3.5b4pre

It'd seem to me that fixing this before releasing firefox 3.5 is important because a release including this bug would prevent web developers from moving to html5, as long as some people use the broken release.

Normally one could have an embed tag within the audio tag as a fall back for browsers that don't yet support the embed tag. If, how ever, there was a browser that would play two songs simultaneously with this markup, it might become unfeasible to start using the new standard before all browsers support it properly.

Reproducible: Always

Steps to Reproduce:
1. create a web page with an audio tag
2. add another audio tag within the first one
3. view the page in firefox 3.5
Actual Results:  
multiple songs are playing at the same time

Expected Results:  
only the outermost audio element should be creating sound as the inner elements are mere fall backs for cases where the outermost element does not work for some reason.

Some one ought to check if the video tag implementation has a similar bug in it.

Updated

9 years ago
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio

Comment 1

9 years ago
Believe it or not this is correct behavior as per spec. See bug 487398.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 487398
You need to log in before you can comment on or make changes to this bug.