Firefox 3 spellchecker hits maximum misspelling limit for some Hotmail users.

RESOLVED DUPLICATE of bug 369815

Status

()

Core
Spelling checker
RESOLVED DUPLICATE of bug 369815
9 years ago
a year ago

People

(Reporter: youngjane1118, Unassigned)

Tracking

16 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.11) Gecko/2009060214 Firefox/3.0.11
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.11) Gecko/2009060214 Firefox/3.0.11

Writing emails has become the worst experience since upgrading my computer and Firefox browser to Firefox 3.

The spellchecker in Firefox 2 which I had on my previous iMac with OS 10.3.5 worked well.  Ever since I got my new iMac (OS 10.5) and upgraded to Firefox 3, writing emails within Hotmail is a terrible experience.

I have to literally copy and paste into a Word document before sending any email, and use the Word spelling checker, then paste that corrected version back into my Hotmail email account before sending my email, since Firefox is incapable of flagging 75% of the misspelled words.

This is making my correspondence, much of it business and not personal, a real pain, plus it is very unprofessional, and a huge waste of my valuable time.

Also Firefox 3 routinely flags correctly spelled words like "didn't" which never occurred in Firefox 2.

I also notice that the longer the email, the less the spell check works.  By the time you get several paragraphs long, it's like it has given up!

I have read many comments from others and bugs filed with your team about the lack of a proper working spell checker, so I know I am not the only person having this problem.  Many have written not to bother submitting a bug about the lousy spell checker in Firefox 3, because Firefox does not seem to care about the fact that it does not work.

The problem has been inherent from the inception of Firefox 3, yet with all the updates you have done, it is not fixed.  Can't you put the spell checker from Firefox 2 back into Firefox 3?  That one never had a single issue whatsoever.  It flagged misspelled words, and left the correctly spelled words alone!

Please try to help all of us that like to use your browser.  You may not think it is that important, but writing with correct spelling and grammar is important to many of us.

Thank you.

 

Reproducible: Always

Steps to Reproduce:
1.Go to Hotmail email account.
2.Start typing.
3.The spell checker begins to skip over misspellings.  It also routinely flags correctly spelled words, like "don't."  This is conistent within Hotmail, and this issue never occurred in Hotmail with Firefox 2, only Firefox 3.
Actual Results:  
Words that are misspelled are not flagged.  Correctly spelled words are flagged as incorrect.  See next:

This is a test for the bug fixers at Firefox.

My Hotmail emails are full of errors i  n  (the i and n are unflagged) spelling that the spell check does not find, and correctly spelled words like didn't (didn't is flagged) are flagged as incorrect.  This ma kes (ma is not flagged) it impossible to communicate professionally with my email program.  Instead I must use Word to compose my email and then paste the corrected version into Hotmail.

The longer I type, the worse the  spell c hek ( c is unflagged, hek is unflagged) performs.  End of test.

Please note, that there is much inconsistency within the spell check, and some of the unflagged words that were copy/pasted in the above example, are now flagged by Firefox in this bug report (hek is flagged here, b ut was not in my hotmail email.  Also see in this and the pr ior sentence that b is unflagged, and pr is unflagged).

Expected Results:  
Errors in spelling should be flagged, and correct words left alone, as was the case in Firefox 2.

Please help with this problem.  Whether it is in Hotmail or any other area where one is typing, the browser should be catching the misspellings!  Firefox 2 never had this issue, only Firefox 3.
(Reporter)

Comment 1

9 years ago
Just want to make sure you know that the problem is not limited to Hotmail; it does occur in other applications where I am typing text into fields, such as within this bug report.

Updated

9 years ago
Component: General → Spelling checker
Product: Firefox → Core
QA Contact: general → spelling-checker

Comment 2

9 years ago
Individual letters are not marked because you cannot misspell a letter. "ma" is not marked because it is a valid word and is spelled properly. As far as "giving up" only the first 500 things get marked.

Are you aware that Hotmail has its own spelling checker? Also, I see that your user agent specifies Mac OS X 10.5. I'm not too familiar with Mac but does this mean you have applied no operating system patches? If that is the case, I encourage you to patch your machine and see if the problem still exists.

If not, what add-ons do you have installed?
(Reporter)

Comment 3

9 years ago
Thank you for your help.  As to individual letters not being marked, Firefox 2 always flagged an individual letter, so I presumed Firefox 3 would do the same.

I do see your point about "ma" not being caught, but the others should have been flagged.  And why Firefox 3 flags correctly spelled words like don't or didn't is beyond me.

Firefox 2 never gave up after 500 words, so I don't understand how a newer version would be less competent.

You are right about Hotmail having its own spelling checker, but it only works with browsers that do not have their own spelling checker.  For example, a long time ago I used Internet Explorer as my browser, and Hotmail's spell check was the only way to check spelling in an email.  When you use a browser like Firefox however, and click on Hotmail's Spell Check, you get the following message:

"You're using a web browser that checks spelling automatically. Look for the words that are flagged by wavy red lines and right-click them to see suggestions."

No operating system patches, and no add-ons installed.

Hope this clarifies things a bit. Thank you again.

Comment 4

9 years ago
Try patching the OS. Does it still happen after that?

Comment 5

9 years ago
It's a possible problem if Hotmail is disabling spell check because of Firefox's spell checker, but Firefox's spell checker has a maximum misspelling limit.

As a workaround, you can change this configuration parameter to allow more misspellings to be corrected. It will slow down Firefox, however.

http://kb.mozillazine.org/Extensions.spellcheck.inline.max-misspellings
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Firefox 3 spellchecker does not work correctly or consistently within Hotmail email. → Firefox 3 spellchecker hits maximum misspelling limit for some Hotmail users.
(Reporter)

Comment 6

9 years ago
To homsar:  Thank you; how does one patch the OS?  When you asked if I had any operating system patches, I thought you were asking if my system was linked to another computer.

To mcaywood:  Thank you for the info; will keep this in mind, although slowing down Firefox may not be my best option; guess it depends on how much slower it would be.  I can certainly compose my emails in Word, run Word's spellcheck, and paste the corrected content into Hotmail.

Still, what ridiculous lengths to have to go through when the old version, Firefox 2, NEVER had this problem!!!  To me, the people who create the browser should just fix the problem so their users don't have to go through contortions to use their browser!

Comment 7

9 years ago
http://support.apple.com/kb/HT1338

Comment 8

9 years ago
Adding myself to the CC list since I've seen this problem a lot in the past.

Comment 9

5 years ago
much of comment 0 is about bug 369815 - Spell Check single character

beyond that, I think I am not able to reproduce this on XP Auroa 20.0a2
anyone else?
Flags: needinfo?
Whiteboard: [closeme 2013-02-01][WFM?]
(Reporter)

Comment 10

5 years ago
Greetings.  I have updated FF many times since posting my bug.  I now have FF 16.0.2. with Mac OS 10.5.8.  Regrettably, the spellchecker is only marginally better than it was years ago when I first reported this issue.  FF spellchecker still routinely flags correctly spelled words, yet does not flag all errors.  There are times when it does not work at all until I purposely spell a word so badly that it cannot ignore the error.  All of a sudden it wakes up, flags that error, and finds several other errors at the same time!  Red dotted lines suddenly appear throughout my document!  This is very frustrating.  I can't tell you how many correspondences I have sent out with errors that were not flagged, only to find the errors after viewing the printed document for my files.

I do not have the time to scan every email 3 times to be sure all errors are caught.  I try to do so before sending, but the eye often sees what it believes was typed.  Of course after hitting "send" and printing the document out, the eyes miraculously find errors that were present and simply not caught.  Not too professional.  Thank you for your continued assistance.
Flags: needinfo?

Updated

5 years ago
Whiteboard: [closeme 2013-02-01][WFM?]
Version: unspecified → 16 Branch

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 369815
You need to log in before you can comment on or make changes to this bug.