All users were logged out of Bugzilla on October 13th, 2018

Crashing at nsBrowserInstance::GetContentAreaDocShell

VERIFIED FIXED

Status

P3
blocker
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: asa, Assigned: hyatt)

Tracking

({crash, smoketest})

Trunk
crash, smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+])

(Reporter)

Description

18 years ago
build 082209 crashes with this output when I click on almost anything. 

Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  1F432490  
  0EE0E340    PPC  1F41CED8  main+00130
  0EE0E2E0    PPC  1F41C29C  main1(int, char**, nsISupports*)+00C0C
  0EE0DFE0    PPC  1F2551C4  nsAppShellService::Run()+00018
  0EE0DFA0    PPC  1BF6D970  nsAppShell::Run()+00048
  0EE0DF50    PPC  1BF6E0AC  nsMacMessagePump::DoMessagePump()+0003C
  0EE0DF00    PPC  1BF6E6B4  nsMacMessagePump::DispatchEvent(int, EventRecord*)+
00174
  0EE0DEB0    PPC  1BF8413C  Repeater::DoRepeaters(const EventRecord&)+00030
  0EE0DE70    PPC  1BF4B208  nsMacNSPREventQueueHandler::RepeatAction(const 
EventRecord&)+000
0C
  0EE0DE30    PPC  1BF4B320  nsMacNSPREventQueueHandler::ProcessPLEventQueue()+
000B0
  0EE0DDC0    PPC  1D885644  nsEventQueueImpl::ProcessPendingEvents()+00038
  0EE0DD50    PPC  1D8E5100  PL_ProcessPendingEvents+0004C
  0EE0DD10    PPC  1D8E51E8  PL_HandleEvent+00020
  0EE0DCD0    PPC  1EF9C0F0  nsStreamListenerEvent::HandlePLEvent(PLEvent*)+00024
  0EE0DC80    PPC  1EF9D340  nsOnDataAvailableEvent::HandleEvent()+00068
  0EE0DC30    PPC  1F01A518  nsHTTPServerListener::OnDataAvailable(nsIChannel*, 
nsISupports*,
 nsIInputStream*, unsigned int, unsigned int)+00C3C
  0EE0D980    PPC  1EFF9D1C  nsHTTPChunkConv::OnDataAvailable(nsIChannel*, 
nsISupports*, nsII
nputStream*, unsigned int, unsigned int)+00370
  0EE0D870    PPC  1EFD0214  InterceptStreamListener::OnDataAvailable(nsIChannel*
, nsISupport
s*, nsIInputStream*, unsigned int, unsigned int)+00060
  0EE0D820    PPC  1F01BE80  nsHTTPFinalListener::OnDataAvailable(nsIChannel*, 
nsISupports*, 
nsIInputStream*, unsigned int, unsigned int)+00094
  0EE0D7C0    PPC  1C066C48  nsDocumentOpenInfo::OnDataAvailable(nsIChannel*, 
nsISupports*, n
sIInputStream*, unsigned int, unsigned int)+00068
  0EE0D760    PPC  1EFEEBF0  nsMultiMixedConv::OnDataAvailable(nsIChannel*, 
nsISupports*, nsI
InputStream*, unsigned int, unsigned int)+00328
  0EE0D6F0    PPC  1EFEFBC8  nsMultiMixedConv::SendStart(nsIChannel*)+0038C
  0EE0D5E0    PPC  1C066A9C  nsDocumentOpenInfo::OnStartRequest(nsIChannel*, 
nsISupports*)+00
0EC
  0EE0D560    PPC  1C0671F0  nsDocumentOpenInfo::DispatchContent(nsIChannel*, 
nsISupports*)+0
041C
  0EE0D370    PPC  1F1C2734  nsBrowserInstance::DoContent(const char*, int, const 
char*, nsIC
hannel*, nsIStreamListener**, int*)+00028
  0EE0D300    PPC  1F1BB914  nsBrowserInstance::GetContentAreaDocShell()+0011C
 Closing log

Steps to reproduce: 
1launch mozilla
2click home on personal toolbar (or almost any ui item including bookmarks menu 
items, other personal toolbar defualt items, etc)
Results: crash
Expected:....
(Reporter)

Comment 1

18 years ago
cc:'ing hyatt and danm in case one of them knows what's happening.  Adding 
smoketest keyword.
Keywords: smoketest

Comment 2

18 years ago
adding self to cc.

this will hold the tree.
I've been seeing this stack trace a lot with the classic skin.  See bug 49822.

Which skin were you using?
(Reporter)

Comment 4

18 years ago
This was tested on a completely clean Installer install with defualt modern
skin.  I just tested on a sea.bin version and default modern skin and I get the
same crash.  I've completely blown away mozilla and all old profiles, registry
files, etc and launched mozilla for the first time, clicking on personal toolbar
bookmark for mozilla.org crashes me.
(Reporter)

Comment 5

18 years ago
same crash if I switch to classic skin as well.
Never mind.  My stack trace was a bit different.

Comment 7

18 years ago
Yes I see this on todays 2000-08-22-06 builds also on commercial..blocker!  
Talkback screen popped up the disappeared.  Could not send in blackbox.
Whiteboard: [dogfood+]

Comment 8

18 years ago
Updating summary, removing moz mozilla since on commercial bits too.  twalker 
was able to get a stack trace.  I crashed just clicking on a link in a browser 
window.  His trace for "crashed while opening new window in composer" is:

.__ptr_glue 
nsBrowserInstance::GetContentAreaDocShell() [nsBrowserInstance.cpp, line 419] 
nsBrowserInstance::CanHandleContent() [nsBrowserInstance.cpp, line 1678] 
nsURILoader::ShouldHandleContent() [nsURILoader.cpp, line 747] 
nsURILoader::DispatchContent() [nsURILoader.cpp, line 815] 
nsDocumentOpenInfo::DispatchContent() [nsURILoader.cpp, line 296] 
nsDocumentOpenInfo::OnStartRequest() [nsURILoader.cpp, line 233] 
nsCachedChromeChannel::HandleStartLoadEvent() [nsChromeProtocolHandler.cpp, line 
513] 
PL_HandleEvent() [plevent.c, line 587] 
PL_ProcessPendingEvents() [plevent.c, line 528] 
nsEventQueueImpl::ProcessPendingEvents() [nsEventQueue.cpp, line 356] 
nsEventQueueImpl::ProcessPendingEvents() [nsEventQueue.cpp, line 362] 
nsMacNSPREventQueueHandler::ProcessPLEventQueue() [nsToolkit.cpp, line 134] 
nsMacNSPREventQueueHandler::RepeatAction() [nsToolkit.cpp, line 99] 
Repeater::DoRepeaters() [nsRepeater.cpp, line 119] 
nsMacMessagePump::DispatchEvent() [nsMacMessagePump.cpp, line 413] 
nsMacMessagePump::DoMessagePump() [nsMacMessagePump.cpp, line 245] 
nsAppShell::Run() [nsAppShell.cpp, line 110] 
nsAppShellService::Run() [nsAppShellService.cpp, line 377] 
main1() [nsAppRunner.cpp, line 946] 
main() [nsAppRunner.cpp, line 1126] 
.__start 
Summary: mac mozilla crashing at nsBrowserInstance::GetContentAreaDocShell → Crashing at nsBrowserInstance::GetContentAreaDocShell

Comment 9

18 years ago
twalker also got the same stack trace as directly above when he "crashed when 
goign to open my email inbox"

Comment 10

18 years ago
I just crashed with similar stack by clicking on a link in the sidebar, using N6
on Mac OS 8.6

Comment 11

18 years ago
cc valeski & hyatt, as saari says they may know of recent changes that affect this.
[ack, mid-air collision. reposting --my mac trace is v.similar to leger's]

i've seen this on commercial builds --moreover, on both Mac and Linux builds
[2000.08.22.08]. updated the summary, platform... on linux i had started out
with a profile in which i had switched to the classic skin; on mac, i didn't
switch the skin at all (still modern).

annoyingly, i cannot seem to reproduce this reliably, but here are the steps i
took (on both mac and linux) before i got the crash:

1. i was in the URLbar, and after *something* (alas, i don't remember the
particular steps here; dunno if it was skin switching, really, since i had
switch skins on the mac --weird) the urlbar would no longer respond after
hitting the enter key, ie, the page wouldn't load. on linux, i got the following
console error:

JavaScript error: 
chrome://navigator/content/sessionHistoryUI.js line 126: gURLBar is not defined

2. so, giving up on the urlbar, i select File > Open Web Location.
3. in the OWL dialog, i type in my url (eg, www.mozilla.org), then hit the Enter
key.

result: crash (tho' not repro). here's the linux talkback info:



nsBrowserInstance::ReinitializeContentVariables() 
nsBrowserInstance::GetContentAreaDocShell() 
nsBrowserInstance::LoadUrl() 
XPTC_InvokeByIndex() 
nsXPCWrappedNativeClass::CallWrappedMethod() 
WrappedNative_CallMethod() 
libmozjs.so + 0x2ac4f (0x40117c4f) 
libmozjs.so + 0x31562 (0x4011e562) 
libmozjs.so + 0x2ac9d (0x40117c9d) 
libmozjs.so + 0x2ae90 (0x40117e90) 
libmozjs.so + 0x11d7f (0x400fed7f) 
nsJSContext::CallEventHandler() 
nsJSEventListener::HandleEvent() 
nsEventListenerManager::HandleEventSubType() 
nsEventListenerManager::HandleEvent() 
nsXULElement::HandleDOMEvent() 
nsXULKeyListenerImpl::HandleEventUsingKeyset() 
nsXULKeyListenerImpl::LocateAndExecuteKeyBinding() 
nsXULKeyListenerImpl::DoKey() 
nsXULKeyListenerImpl::KeyPress() 
nsEventListenerManager::HandleEvent() 
nsXULDocument::HandleDOMEvent() 
nsXULElement::HandleDOMEvent() 
nsXULElement::HandleDOMEvent() 
nsXULElement::HandleDOMEvent() 
nsXULElement::HandleDOMEvent() 
nsXULElement::HandleDOMEvent() 
nsXULElement::HandleDOMEvent() 
nsGenericElement::HandleDOMEvent() 
nsHTMLInputElement::HandleDOMEvent() 
PresShell::HandleEventInternal() 
PresShell::HandleEvent() 
nsView::HandleEvent() 
nsViewManager2::DispatchEvent() 
HandleEvent() 
nsWidget::DispatchEvent() 
nsWidget::DispatchWindowEvent() 
nsWidget::OnInput() 
handle_key_press_event() 
dispatch_superwin_event() 
handle_gdk_event() 
libgdk-1.2.so.0 + 0x174db (0x407374db) 
libglib-1.2.so.0 + 0x10186 (0x40767186) 
libglib-1.2.so.0 + 0x10751 (0x40767751) 
libglib-1.2.so.0 + 0x10804 (0x40767804) 
nsAppShell::DispatchNativeEvent() 
nsXULWindow::ShowModal() 
nsWebShellWindow::ShowModal() 
nsChromeTreeOwner::ShowModal() 
GlobalWindowImpl::OpenInternal() 
GlobalWindowImpl::OpenDialog() 
WindowOpenDialog() 
libmozjs.so + 0x2ac4f (0x40117c4f) 
libmozjs.so + 0x31562 (0x4011e562) 
libmozjs.so + 0x2ac9d (0x40117c9d) 
libmozjs.so + 0x2ae90 (0x40117e90) 
libmozjs.so + 0x11d7f (0x400fed7f) 
nsJSContext::CallEventHandler() 
nsJSEventListener::HandleEvent() 
nsEventListenerManager::HandleEventSubType() 
nsEventListenerManager::HandleEvent() 
nsXULElement::HandleDOMEvent() 
PresShell::HandleDOMEventWithTarget() 
nsMenuFrame::Execute() 
nsMenuFrame::HandleEvent() 
PresShell::HandleEventInternal() 
PresShell::HandleEvent() 
nsView::HandleEvent() 
nsView::HandleEvent() 
nsView::HandleEvent() 
nsView::HandleEvent() 
nsViewManager2::DispatchEvent() 
HandleEvent() 
nsWidget::DispatchEvent() 
nsWidget::DispatchWindowEvent() 
nsWidget::DispatchMouseEvent() 
nsWidget::OnButtonReleaseSignal() 
nsWindow::HandleGDKEvent() 
dispatch_superwin_event() 
handle_gdk_event() 
libgdk-1.2.so.0 + 0x174db (0x407374db) 
libglib-1.2.so.0 + 0x10186 (0x40767186) 
libglib-1.2.so.0 + 0x10751 (0x40767751) 
libglib-1.2.so.0 + 0x108f1 (0x407678f1) 
libgtk-1.2.so.0 + 0x8c5b9 (0x4068c5b9) 
nsAppShell::Run() 
nsAppShellService::Run() 
main1() 
main() 
libc.so.6 + 0x189cb (0x4024d9cb)


...and here's the mac trace info:

.__ptr_glue 
nsBrowserInstance::GetContentAreaDocShell() [nsBrowserInstance.cpp, line 419] 
nsBrowserInstance::LoadUrl() [nsBrowserInstance.cpp, line 570] 
CODE.10 
XPTC_InvokeByIndex() [xptcinvoke_mac.cpp, line 129] 
nsXPCWrappedNativeClass::CallWrappedMethod() [xpcwrappednativeclass.cpp, line
909] 
WrappedNative_CallMethod() [xpcwrappednativejsops.cpp, line 224] 
js_Invoke() [jsinterp.c, line 714] 
js_Interpret() [jsinterp.c, line 2517] 
js_Invoke() [jsinterp.c, line 732] 
js_InternalInvoke() [jsinterp.c, line 804] 
JS_CallFunctionValue() [jsapi.c, line 3146] 
DOM_DLL + 0xe8a8 (0x0585d858) 
DOM_DLL + 0x6dd94 (0x058bcd44) 
nsEventListenerManager::HandleEventSubType() [nsEventListenerManager.cpp, line
788] 
nsEventListenerManager::HandleEvent() [nsEventListenerManager.cpp, line 1666] 
(Assignee)

Comment 13

18 years ago
dan and I are looking at it.
Assignee: asa → hyatt
(Assignee)

Comment 14

18 years ago
--> danm
Assignee: hyatt → danm

Comment 15

18 years ago
From what I'm seeing, the reason for the crash is in
nsBrowserInstance::ReinitializeContextVariables(), on the line
'mDOMWindow->Get_content(getter_AddRefs(content));'. The problem is that
mDOMWindow is NULL, whoops.

Comment 16

18 years ago
warren- is this caused by your check in ? The first stack trace show 
OnDataAvailable on the stack.

Comment 17

18 years ago
add warren to the cc list since he change stream listener yesterday and stream 
listener is on the first stack

Comment 18

18 years ago
Conrad says this is his.

Comment 19

18 years ago
whoops, previous comment was for another bug. Never mind.

Comment 20

18 years ago
I have old source in my tree, the mDOMWindow is set by 
nsBrowserIntance::SetWebShellWindow when I open a new browser window.
hyatt said nsBrowserIntance::SetWebShellWindow  didn't get called. And he also 
see some JavaScript error there about window._content cannot be found
bluh, i fergot to add the kw's after that collision. doing so now...
Keywords: crash, nsbeta3
Hardware: Macintosh → All
(Assignee)

Comment 22

18 years ago
have a fix.  coding it now.

Comment 23

18 years ago
.
Assignee: danm → hyatt
(Assignee)

Comment 24

18 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 25

18 years ago
I'm fairly certain this bug is no longer there.  I'll mark verified.  Cleaning 
up old resolved smoketest bugs.
Status: RESOLVED → VERIFIED
OS: All
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.