Crash while loading email

RESOLVED INVALID

Status

Thunderbird
General
--
critical
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Evans Jahja, Unassigned)

Tracking

({crash})

x86_64
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.11) Gecko/2009060309 Ubuntu/9.04 (jaunty) Firefox/3.0.11
Build Identifier: 2.0.0.21 (20090409)

After launching Thunderbird, it prompt my password. After entering, it says connecting to server localhost (I use webmail, so I guess this is normal). Then, after about 1 or 2 minutes it crash (actually, it turns gray, this is ubuntu).

Reproducible: Always

Steps to Reproduce:
1.Launch Thunderbird
2.Enter password
Actual Results:  
it crash, I'll try to send the backtrace.

Expected Results:  
Duh, able to at least get the mail from Thunderbird ;)
(Reporter)

Comment 1

9 years ago
Created attachment 383293 [details]
Backtrace
(Reporter)

Comment 2

9 years ago
Additional information: I use Yahoo Mail Classic with Classic Mail on the Webmail. I also have the latest version of the Webmail and the Webmail Yahoo extension.
if you run in safe-mode does it crash ? if not is it crashing because of the Yahoo! extension ?
Severity: major → critical
Keywords: crash
Version: unspecified → 2.0
(In reply to comment #1)
> Created an attachment (id=383293) [details]
> Backtrace

This trace isn't really useful because there aren't any symbols. To get symbols, try and run a nightly build at http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/

and run the following command:

sudo apt-get install libatk1.0-dbg libc6-dbg libcairo2-dbg \
 libfontconfig1-dbg libgcc1-dbg libglib2.0-0-dbg libgnomeui-0-dbg \
 libgnomevfs2-0-dbg libgnutls13-dbg libgtk2.0-0-dbg libice6-dbg \
 libjpeg62-dbg libpango1.0-0-dbg libpixman-1-0-dbg libstdc++6-4.2-dbg \
 libx11-6-dbg libx11-xcb1-dbg libxcb1-dbg libxft2-dbg zlib1g-dbg

https://developer.mozilla.org/en/Debugging_Mozilla_with_gdb#section_22

and try to reproduce the crash in TB in safe mode. If it crashes, please also attach a testcase with any sensitive / private information removed.
Judging from the stack--two entries in libc, followed by a stack in libmozjs--this is most likely a crash brought about by a JS bug, not any bug on Thunderbird's part. Without any function or line information, I have absolutely no idea what the bug might be.

I would recommend that you try it with a recent nightly, but I'm betting that the crash is really a JS (GC-related?) error happening on the Webmail extension code, which I'm pretty sure doesn't work on nightlies.
(Reporter)

Comment 6

9 years ago
I've tried running Thunderbird in safe mode. The bug doesn't occur in the safe mode, probably because the webmail is disabled.
Also, when there are no message on the server, thunderbird runs fine, but when there is at least one message, it crash like before.
(In reply to comment #6)
> I've tried running Thunderbird in safe mode. The bug doesn't occur in the safe
> mode, probably because the webmail is disabled.

Because the crash doesn't occur in safe mode, it's a bug in the extension then. Please report the issue at the extension web location.

-> Invalid, not a TB bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.