Disk space shortage during update produces loop

RESOLVED DUPLICATE of bug 315278

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 315278
9 years ago
9 years ago

People

(Reporter: George R. Goffe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090525 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090525 Minefield/3.6a1pre

During daily update of minefield, a loop appeared. strace -xvfp <pid> showed a ENOSPAC loop.

Reproducible: Always

Actual Results:  
No update until disk space problem resolved... Update proceeded "normally" but appeared to require more prompts which had already been "poked" once.

Expected Results:  
Update success or a failure message.

Perhaps some sort of dialog would be a good idea?

Loop:
 out of space msg
 prompt user for action (resolve the space problem and retry or abort)?
 loop
Component: Installer → Application Update
Product: Firefox → Toolkit
QA Contact: installer → application.update
Whiteboard: [DUPEME]
(Reporter)

Comment 1

9 years ago
After the update was done, Minefield did NOT restart itself as it usually does.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 315278
(Reporter)

Comment 3

9 years ago
Howdy,

I have looked at 315278 and the concept of a loop does NOT appear to be mentioned.

Thanks.

George...
There are several different symptoms that can occur when disk space is low and the loop is just one of these. I'll mention that as a possible symptom
You need to log in before you can comment on or make changes to this bug.