Mac and Windows installer component names not synced

RESOLVED INVALID

Status

SeaMonkey
Installer
P3
normal
RESOLVED INVALID
18 years ago
13 years ago

People

(Reporter: Henrik Gemal, Assigned: Curt Patrick (gone))

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
The Mac installer and the Windows are not synced. Meaning the fx the component 
names are different on the mac than on the Windows.
Also the mac has more setup screens like the create shortcuts, etc...
(Reporter)

Comment 1

18 years ago
It's kind of shocking to see the difference between the installers. Different 
wordings, different component names, different setup types and options, 
different license (win32 has none), etc....
What about the UNiX version. I havn't tried it, so I'm blank there...
Anybody else should be on the Cc?

Comment 2

18 years ago
IMHO, this is a feature, not a bug.  The stub installers are platform-specific 
and thus must adhere to platform-specific UI expectations.  Matthew, Eli, etc. 
have logged numerous bugs against the Mac installer (much appreciated) for 
tweaks to make it more "Mac-like" and a number of these have been fixed.  For 
example, if we referred to 'folders' as 'directories' on the Mac that would be 
unacceptable and inaccurate.  We took a similar approach for the Linux installer 
too.

Now, the component names is a different story.  We should sync these up and 
maybe that's what this bug should morph into.  Please be specific about what 
component names are out of sync.  Thanks.
(Reporter)

Comment 3

18 years ago
There are a bug out on the comp names in the Win32 installer. Perhaps it will 
get fixed.
http://bugzilla.mozilla.org/show_bug.cgi?id=47959

- Why do the Mac installer show a license?
Also some of the error messages could be synced up...

Will take a closer look at the mac version when I get near a Mac...

Comment 4

18 years ago
Samir, I don't think it's as bad as all that. Apart from details like the exact 
appearance of the widgets, the folders/directories terminology, and the order 
of `Ok'/`Cancel' buttons, I think the installers should look and work pretty 
much identically across platforms. (Sounds like time for a UI spec ...)

The Mac installer license issue is bug 18904.
(Reporter)

Comment 5

18 years ago
Some of the differences:
- License on Mac not on Win32 (bug 51499)
- Setup types (Mac has "Custom Install" and "Typical Install", Win32 has "Base", 
"Complete" and "Custom")
- disk space wordings (bug 51501)
- Componentnames (Mac has "Navigator", "Mail & News" and "Chatzilla", Win32 has 
"Mozilla Seamonkey", "Mail & News" and "Chatzilla") (bug 47959)
- Missing about dialog in Win32 installer (bug 33345) ....:)

Updated

18 years ago
Depends on: 51499

Comment 6

18 years ago
adding myself to cc list

Comment 7

17 years ago
over to Curt.
Assignee: ssu → curt
Target Milestone: --- → Future
(Reporter)

Comment 8

17 years ago
since the component names have been set to the same...
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

17 years ago
For post 1.0 I intend to focus on trying to sync up the three installers as much
as possible.  I think that some probing would uncover several areas where
improvements could be made such as config.ini syntax, perhaps further sync'ing
of ui, surgical upgrade installs for a few that come to mind off the top of my
head.  I'm not sure how best to track those things.  The title of this bug
sounds like it could be reopened as a meta-bug for tracking these issues...or
maybe a new bug should be opened?  Probably the latter since this bug seems to
be looking at some pretty specific issues?

Comment 10

17 years ago
Henrik,

I am seeing differences between component names  Mac (Mail & News) Win (Mail & 
Newsgroups)
Also the descriptions in box below on custom setup type have changed- should ths 
be reopened - perhaps as Curt suggests to track sync'ing later?
(Reporter)

Comment 11

17 years ago
I thought that bug 123975 fixed all that????
And we still have a serious problem with the PSM description, see bug 127808
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

17 years ago
Blocks: 130715
(Assignee)

Comment 12

17 years ago
This 'caused this to go out of sync by changing the windows component name
without changing the mac equivalent.

Bug 123975 dealt specifically with component description, many of which we
changed.  That should all be in sync now.

Also, I just opened a meta bug for tracking anything else we find to be out of
sync on the different platforms--bug 130715--and this bug is linked to it.
Status: REOPENED → ASSIGNED
Summary: Mac and Windows installer not synced → Mac and Windows installer component names not synced
Product: Browser → Seamonkey

Comment 13

13 years ago
This doesn't appear to be applicable any more...
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.