If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Opening nyse.com causes crash with flash 9

VERIFIED WORKSFORME

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
VERIFIED WORKSFORME
8 years ago
a year ago

People

(Reporter: paul.hermeneutic, Assigned: Michelle Sintov)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: 10.0 r12, URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009042700 SUSE/3.0.10-1.1 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009042700 SUSE/3.0.10-1.1 Firefox/3.0.10

Opening the URL causes all Firefox browser windows to close.  No crash report appears to be created.

I am on openSUSE 11.0

Linux linux-3eb6 2.6.25.20-0.4-pae #1 SMP 2009-06-01 09:57:12 +0200 i686 i686 i386 GNU/Linux

Reproducible: Always

Steps to Reproduce:
1.  Open http://www.nyse.com/
2.  All Firefox browser windows close
3.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0 Branch
Well, it looks like you are using a linux distro of firefox, which will not give a crash report. You can download one from http://www.mozilla.com/, or use http://www.mozilla.com/en-US/ to try to get a debug. Also, try in safe mode and with a new profile.
Severity: normal → critical
Keywords: crash
Summary: Opening the URL causes all Firefox browser windows to close → Opening nyse.com causes crash
(Reporter)

Comment 2

8 years ago
Running in -safe-mode produces several  "Flash Player" warning lines followed by a segfault.

"""
Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8
/usr/bin/firefox: line 126:  7935 Segmentation fault      $MOZ_PROGRAM "$@"
"""

When I start Firefox to create a new profile, it appears to open without any -ProfileManager.  Is this because I am on Firefox from the openSUSE distro?

    firefox -ProfileManager

This is pretty easy to try.  Does it happen on your machine?

    http://www.nyse.com/
Works for me, Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.11) Gecko/2009060309 Ubuntu/9.04 (jaunty) Firefox/3.0.11
(64-bit Ubuntu distro build, with Flash 10.0 r22)

Works for me, Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.0.12pre) Gecko/2009061004 GranParadiso/3.0.12pre
with Flash 10.0 r12
(Reporter)

Comment 4

8 years ago
Upgrading from Flash 9 to the current Adobe Flashplayer 10.0.r22 appears to resolve the problem.

Take note that the Adobe installer does not work well on SUSE 11.0.  See the page at:

http://bugs.adobe.com/jira/browse/FP-1521
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
ok, flash is invalid, not a bug in firefox
Resolution: FIXED → INVALID

Comment 6

8 years ago
so... if it's flash, then a copy of the flash output from before it crashes would be nice :) but if it's fixed in 10, i expect that's it, as most groups (dunno about flash) don't maintain multiple major versions
Assignee: nobody → msintov
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Summary: Opening nyse.com causes crash → Opening nyse.com causes crash with flash 9
Version: 3.0 Branch → 1.9.0 Branch
(Reporter)

Comment 7

8 years ago
Ok, so it is not a Firefox bug.

This still suggests that Flash can bring down all of Firefox.  Is there anything Firefox can do to limit the damage and not have all Firefox window instances close?
Resolution: INVALID → FIXED
fixed is only for when a patch is checked into the firefox tree, which has not happened here.

We could run the plugin in a separate process, which is another bug I think. That would keep firefox open when flash crashes, and would just end the flash instance.
Resolution: FIXED → INVALID

Updated

8 years ago
Status: RESOLVED → VERIFIED
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Resolution: INVALID → WORKSFORME
Whiteboard: 10.0 r12
Version: 1.9.0 Branch → 9.x

Comment 9

a year ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 9.x → unspecified
You need to log in before you can comment on or make changes to this bug.