Opening an second mail in the standalone window just loads the message that's already open

VERIFIED FIXED

Status

defect
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: robert.cox, Unassigned)

Tracking

(Blocks 1 bug, {regression})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 467768])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506)
Build Identifier: 

When you open an email and an email is already opened, the window that is opened is the already opened email.  Trying to put that in English again.  It appears like double clicking opens the wrong email, byut actually it has brought to the front the open window of another email.

Reproducible: Always

Steps to Reproduce:
1. open email and view
2. open another email (you see the original email)
3.
Actual Results:  
closed both open emails and ensured that i only ever had one windows open.

Expected Results:  
should open another window with the contents of the second selected email

This is only in Shreader 3.0 PreBeta3 as of 2 days ago
(Reporter)

Comment 1

10 years ago
Still occuring on 
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1pre) Gecko/20090616 Lightning/1.0pre Shredder/3.0b3pre
Robert what do you have in Preferences -> Reading and Display, Open Messages in: ?
WFM on linux
Keywords: regression
Summary: Opening an email loads the wrong email → Opening an second mail in the standalone window just loads the message that's already open
Robert?

if your problem is gone please close this bug with resolution set to WORKSFORME.
Severity: critical → normal
Component: General → Message Reader UI
QA Contact: general → message-reader
Version: unspecified → Trunk
Whiteboard: closeme 2009-07-09
Confirmed with 2009/6/21 build on MS Win-XP SP3.
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090621 Shredder/3.0b3pre

[Steps to reproduce]
(0) Preferences->Reading and Display, Open Messages in: An existing message window
(1) Open mail-1 in stand-alone window-1 via "Open Message in New Window"
(2) Open mail-2 in stand-alone window-2 via "Open Message in New Window"
(3-1) Click stand-alone window-1(becomes top layer window)
(3-2) Click mail-3 at thread pane(mail 3 is displayed in message pane)
(3-3) Double-Click mail-3
      => stand-alone window-1 gets focus. still mail-1 is displayed
(3-4) Double-Click mail-3 again => mail-3 is displayed in stand-alone window-1
(4-1) Click stand-alone window-2(becomes top layer window)
(4-2) Click mail-4 at thread pane(mail-4 is displayed in message pane)
(4-3) Double-Click mail-4
      => stand-alone window-2 gets focus. still mail-2 is displayed
(4-4) Double-Click mail-4 again => mail-4 is displayed in stand-alone window-2

If single stand-alone window, phenomenon at (3-3) or (4/3) looks "double-click of a mail displays previous mail".
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: closeme 2009-07-09
(Reporter)

Comment 6

10 years ago
Yes - I have open message in an existing mesage window - not sure why, might ahve changed with an update, since i didn't change it.  But yes WADA is correct.
Could you try this with the latest nightly (June 29)? This might have been fixed by bug 467768 -- I can't reproduce the issue with the STR in comment 5.
(In reply to comment #7)

> I can't reproduce the issue with the STR in comment 5.

Me too with next build on MS Win-XP SP 3.
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090629 Shredder/3.0b3pre

Putting "fixed-by-bug-467768" in Whiteboard: field. Correct it please, if wrong.
Whiteboard: ixed-by-bug-467768
Marking fixed. Please reopen if you still see this issue.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: ixed-by-bug-467768 → [fixed by bug 467768]
(Reporter)

Comment 10

10 years ago
Confirmation again that is works for me (a.k.a fixed) on Vista with 30 June build.
based on comment #10 -> VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.