AOL mail corrupting binary attachment uploads

RESOLVED FIXED

Status

Tech Evangelism
Desktop
--
critical
RESOLVED FIXED
9 years ago
4 years ago

People

(Reporter: zzxc, Unassigned)

Tracking

({common-issue-})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Several users on SUMO have reported that AOL mail is corrupting all binary attachments uploads when sent via Firefox.  Examining an uploaded file before and after, it seems that 0x0D carriage return characters are being converted to 0x0A, resulting in binary corruption.
(Reporter)

Comment 1

9 years ago
Created attachment 383359 [details]
Original file before attaching
(Reporter)

Comment 2

9 years ago
Created attachment 383360 [details]
File after attaching and sending via aol mail

Comment 3

9 years ago
Doing some testing on my account on aol mail, not able to reproduce but when I tried to send once it told me that my attachment was too large and the second time it went through without corruption.  It may not happen on all accounts.
I didn't have much luck trying to replicate the problem on 3.0.11 on a Vista vm. I sent an installer to myself, then saved the attachment and ran it. It worked fine.

Comment 5

9 years ago
Do see this much anymore... They may have fixed something.
Keywords: common-issue+ → common-issue-

Comment 6

4 years ago
According to previous comments.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: English US → Desktop
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.