gloda error (labeled as warning): Got impossible folder ID

RESOLVED FIXED in Thunderbird 3.0rc1

Status

MailNews Core
Database
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: davida, Assigned: asuth)

Tracking

unspecified
Thunderbird 3.0rc1
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact][gloda key])

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
I see this in error console

2009-06-15 11:16:08	gloda.indexer	WARN	Problem during job, trying to recover.  Problem was at undefined:undefined: Got impossible folder ID: 80

No idea why.
(Assignee)

Comment 1

8 years ago
Created attachment 389447 [details] [diff] [review]
[committed in comment 2] v1 provide more detail on the job we're abandoning

A brief code inspection at the probable origins of such an error yielded nothing.

This patch gets us more debug about what the job is that we're abandoning.  Since my patch for bug 498222 also had a similar idea, note that there will be a conflict between that fix patch and this patch, but this is the one that should win.  (It's more polished and actually has the job describe what it's doing.)

Here's an example (with reduced paths) of what the bug provides (using the failure from bug 498222 as the example):

2009-07-20 03:44:34	gloda.indexer	WARN	Problem during [job:folder delta:0 id:82 items:0 offset:1 goal:3], trying to recover.  Problem was at file:///.../noun_mimetype.js:178: TypeError: aMimeType is undefined. Stack:
  gloda_noun_freetag_toParamAndValue((void 0))@file:///.../noun_mimetype.js:178
  gloda_attr_convertValuesToDBAttributes([object Array])@file:///.../datamodel.js:132
  gloda_ns_grokNounItem([object Object],[object Object],false,false,[object Object],(void 0))@file:///.../gloda.js:1665
  gloda_index_workBatch()@file:///.../indexer.js:1357
  gloda_index_callbackDriver()@file:///.../indexer.js:1224
  gloda_index_wrapCallbackDriver([object XPCWrappedNative_NoHelper])@file:///.../indexer.js:1161
Attachment #389447 - Flags: review?(bienvenu)

Updated

8 years ago
Attachment #389447 - Flags: review?(bienvenu) → review+
(Assignee)

Comment 2

8 years ago
pushed improved error logging:
http://build.mozillamessaging.com/mercurial/comm-central/rev/f33c2acfd4cb
(Assignee)

Updated

8 years ago
Attachment #389447 - Attachment description: v1 provide more detail on the job we're abandoning → [committed in comment 2] v1 provide more detail on the job we're abandoning
(Reporter)

Comment 3

8 years ago
More data.

2009-07-28 14:19:58	gloda.indexer	DEBUG	<<<  _indexMessage
2009-07-28 14:19:58	gloda.indexer	DEBUG	>>>  _indexMessage
2009-07-28 14:19:58	gloda.indexer	DEBUG	*** Indexing message: 302062 : [Bug 395701] mailnews should use nsStringGlue and other Glue code
2009-07-28 14:19:58	gloda.datastore	DEBUG	QUERY FROM QUERY: SELECT * FROM conversations WHERE (id IN (235)) ARGS: 
2009-07-28 14:19:58	gloda.ds.mbm	DEBUG	getting results...
2009-07-28 14:19:58	gloda.ds.mbm	DEBUG	query completed, notifying... Message:660,Message:661,Message:1014
2009-07-28 14:19:58	gloda.indexer	DEBUG	ancestors raw: Message:660,Message:661,Message:1014
2009-07-28 14:19:58	gloda.indexer	DEBUG	ref len: 2 anc len: 2
2009-07-28 14:19:58	gloda.indexer	DEBUG	references: 0 = bug-395701-288265@https.bugzilla.mozilla.org/,1 = 200903161026.n2GAQivb029196@mrapp51.mozilla.org
2009-07-28 14:19:58	gloda.indexer	DEBUG	ancestors: 0 = Message:660,1 = Message:661,Message:1014
2009-07-28 14:19:58	gloda.indexer	DEBUG	2 candidate messages
2009-07-28 14:19:58	gloda.indexer	DEBUG	candidate folderID: 35 messageKey: 258
2009-07-28 14:19:58	gloda.indexer	DEBUG	candidate folderID: 16 messageKey: 302062
2009-07-28 14:19:58	gloda.indexer	WARN	Problem during job, trying to recover.  Problem was at undefined:undefined: Got impossible folder ID: 16


The cause was likely an IMAP rename, which caused all kinds of unhappiness.

Marking blocking, as it seems to stop further indexing of messages in the affected folder, which is bad.
Flags: blocking-thunderbird3+
Summary: gloda warning: Got impossible folder ID → gloda error (labeled as warning): Got impossible folder ID
Marking this as "[no l10n impact]" for now. But if we decide to move the error message into localizable space that would change.
Whiteboard: [no l10n impact]
(Reporter)

Comment 5

8 years ago
Andrew, what should the milestone for this bug be?
Assignee: nobody → bugmail
Target Milestone: --- → Thunderbird 3.0rc1
(Assignee)

Comment 6

8 years ago
With the "more data" from comment #3 I understand the problem now.  The problem is that the ghost message's state is illegal but possible.  This will likely be resolved by proper deletion logic, but a minor change may be required here.  Moving to beta 4 to be with its gloda key friends.
Status: NEW → ASSIGNED
Whiteboard: [no l10n impact] → [no l10n impact][gloda key]
Target Milestone: Thunderbird 3.0rc1 → Thunderbird 3.0b4
(Reporter)

Updated

8 years ago
Whiteboard: [no l10n impact][gloda key] → [no l10n impact][gloda key][root cause is bug 465618]
Target Milestone: Thunderbird 3.0b4 → Thunderbird 3.0rc1
(Assignee)

Comment 7

8 years ago
Created attachment 400602 [details] [diff] [review]
v1 workaround having a bad folderid.  this should probably improve things enough.
Attachment #400602 - Flags: review?(bienvenu)

Comment 8

8 years ago
Comment on attachment 400602 [details] [diff] [review]
v1 workaround having a bad folderid.  this should probably improve things enough.

looks reasonable.
Attachment #400602 - Flags: review?(bienvenu) → review+
Attachment #400602 - Flags: approval-thunderbird3+
(Assignee)

Updated

8 years ago
Whiteboard: [no l10n impact][gloda key][root cause is bug 465618] → [no l10n impact][gloda key][will be fixed by gloda correctness patch]
(Assignee)

Comment 9

8 years ago
Fixed in gloda correctness patch tracked on bug 465618.
trunk commit: http://hg.mozilla.org/comm-central/rev/413b2018349c

The fix marking is actually for the commit of the workaround patch which landed in commit: http://hg.mozilla.org/comm-central/rev/cbae38f29de7
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [no l10n impact][gloda key][will be fixed by gloda correctness patch] → [no l10n impact][gloda key]

Updated

8 years ago
Keywords: fixed-seamonkey2.0.1

Updated

8 years ago
Keywords: fixed-seamonkey2.0.1
You need to log in before you can comment on or make changes to this bug.