Flash animation not repainted properly after resizing window

VERIFIED DUPLICATE of bug 37126

Status

Core Graveyard
GFX
P3
normal
VERIFIED DUPLICATE of bug 37126
18 years ago
9 years ago

People

(Reporter: Chris Petersen, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Build: 2000082209
Platform: Mac
Other Platform: Works on Win 98.
Expected Results:Flash animation should be repainted after scrolling or resizing 
window.
What I got: After resizing the window, the Flash animation is only partially 
repainted.

Steps to reproduce:

1) open url.

2) flash animation should be rendered below disney banner on the page.

3) Resize or scroll the page's window.

4) The animation turns "white" and then only partially repaints this area.
General Mac plug-in brokenness. Duplicate of 37126?
Keywords: flash
(Reporter)

Comment 2

18 years ago
Nominamting for beta3. This problem is awful on the mac right now. Works fine on 
Windows build and on Mac Nav 4.7/Mac IE 5.0. 
Keywords: nsbeta3
OS: Mac System 8.5 → Mac System 9.0
(Assignee)

Comment 3

18 years ago
This bug is really a dup of the general Mac problem outlined in 37126. The basic 
problem seems to be that we must not double buffer the view that is used to 
render the Mac plugin. The plugin view should render directly to the window.

*** This bug has been marked as a duplicate of 37126 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
Verified dupe of bug 37126: "Flash animation displays as mostly gray, only
bottom is displayed"
Status: RESOLVED → VERIFIED
OS: Mac System 9.x
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.