Wrong behavior of crypt function in Firefox 3.5 Preview (with JIT for content enabled)

RESOLVED WORKSFORME

Status

()

P1
critical
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: kondzior.p, Assigned: gal)

Tracking

1.9.1 Branch
mozilla1.9.1
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: regression, regression-window-needed)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99

Crypt is class for client side password hashing with salt, it's broke on firefox 3.5 Preview with JIT for content enabled

Reproducible: Always

Steps to Reproduce:
1. Open attached test case in Firefox 3.5 Preview
2. Result is and Should be values will be different



I use this crypt function for hashing password from client side on my site, with Firefox 3.5 Preview users cannot log in to my page.
(Reporter)

Comment 1

10 years ago
Created attachment 383432 [details]
Testcase
(Reporter)

Updated

10 years ago
Version: unspecified → 3.5 Branch
(Reporter)

Updated

10 years ago
Flags: blocking-firefox3.5?

Updated

10 years ago
Assignee: nobody → general
Component: General → JavaScript Engine
Flags: blocking-firefox3.5?
Product: Firefox → Core
QA Contact: general → general
Version: 3.5 Branch → 1.9.1 Branch
(Assignee)

Comment 2

10 years ago
Investigating. If I can confirm this, we probably have to block on it. Asking for b? in the meantime. Hold off on b+ until I looked at it.
Assignee: general → gal
Severity: major → critical
Flags: blocking1.9.1?
Priority: -- → P1
Target Milestone: --- → mozilla1.9.1

Comment 3

10 years ago
Andreas, I apologize for ever having written code (well, ported it, see the comment from the original source linked below) so ugly as that and for making you grovel through it:

http://whereswalden.com/tech/internet/javacrypt/

Comment 4

10 years ago
The (my!) testcase works for me in a 20090615 nightly; with any luck we fixed this between 20090605 and now -- not implausible given some of the bugs fixed in that time.
(Assignee)

Comment 5

10 years ago
This works in TM tip shell. We need a regression window.
Whiteboard: regression, regression-window-needed
(Assignee)

Comment 6

10 years ago
Confirmed to work in 1.9.1 tip shell. Closing as WFM based on Waldo's and my own testing. Pawel, can you confirm with rc1?

(we should still bisect this)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Flags: blocking1.9.1?
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

10 years ago
With Firefox 3.5 RC1 crypt() works ok. testcase result is correct, and i can loggin on my page.
You need to log in before you can comment on or make changes to this bug.