Update Graph Server to jquery 1.4

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
10 years ago
2 years ago

People

(Reporter: Swatinem, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Graph Server has been unusable recently, throwing a lot of slow script warnings.
A quick profile showed "remove" as one possible culprit with more than 60000 calls.
John Resig has blogged about that method a while ago: http://ejohn.org/blog/function-call-profiling/

The underlying bug has been fixed in jQuery nightlies only so far.

Updating to jQuery nightly removes "remove" from the profile and makes the usage experience a lot more pleasant. Still hangs for 1-2 Seconds refreshing the test list (which includes 3500+ tables), but that is far better than before.
Arpad: yeah, the graph server is quite slow. We have a few performance improvements that we are hoping to push today to graphs-new.mozilla.org (our re-written codebase we're hoping to release soon)

The staging server for our new codebase is http://graphs-stage2.mozilla.org/graph.html if you want to see the difference in speed. (the data stored is not valid fyi)
Marking as invalid as the latest code doesn't throw slow script warnings anymore.

Arpad, if you still have issues with the code on graphs-stage2.mozilla.org please let us know.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
OS: Linux → All
Hardware: x86 → All
Resolution: --- → INVALID
(Reporter)

Comment 3

10 years ago
It is at least usable.

Firebug profile says that updateAvailableTests takes 4,4s switching from Branch All (2800 entries) to branch Firefox (800)

With the latest jQuery nightly, the profile says 1,4s switching from All (3500 entries like the production version currently has) to Firefox (900)

Thats a speedup of 3 with very little effort.
Arpad: thanks for benchmarking that. I will update the nightly we are using and test.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Just tested with latest jQuery nightly, it's definitely much faster, but there is a regression where discrete test data won't load. Will have to debug.
(Reporter)

Updated

9 years ago
Summary: Update Graph Server to latest jquery nightly → Update Graph Server to jquery 1.4
(Reporter)

Updated

9 years ago
Blocks: 489735

Comment 6

9 years ago
Created attachment 451557 [details] [diff] [review]
Upgrade to jQuery 1.4.2

This patch omits the removal of jq/jquery-1.2.1.js and jq/jquery-nightly.js, and the addition of jq/jquery-1.4.2.js for readability. Also, jq/jquery.ui-1.0/* could/should probably be removed.

This patch is for upgrading to jQuery 1.4.2 which is the current stable version. But according to http://en.wikipedia.org/wiki/JQuery it was released February 19, 2010 which should make it newer than the requested nightly from 2009-06-16.

I could not reproduce the problem from comment 5. Instead there was a problem that all lines in the graph had the same color. It turned out that the events from TinderboxData where called multiple times, probably because the __TinderboxData...-div used as eventTarget was reused for all instances. Since the cost (i.e. making sure the the events was only triggered once) seemed higher that the benefit, the events have, so to speak, been replaced by callbacks.

Comment 7

6 years ago
Could somebody please close this bug. The graph-server have been replaced.
(Reporter)

Comment 8

5 years ago
Per comment 7.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago5 years ago
Resolution: --- → INCOMPLETE
(Assignee)

Updated

2 years ago
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.