Many messages "deleted" from Inbox after sending message

RESOLVED INVALID

Status

MailNews Core
Networking: IMAP
RESOLVED INVALID
9 years ago
7 years ago

People

(Reporter: Christopher Galik, Unassigned)

Tracking

1.9.1 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_7; en-us) AppleWebKit/530.17 (KHTML, like Gecko) Version/4.0 Safari/530.17
Build Identifier: 3.0b3pre

When I send a message (admittedly, not all the time, still trying to nail down a pattern), many of my messages claim to be deleted from my Inbox.  They disappear from the list, and a message appears in the status bar, stating "Deleted xxxx messages," where xxxx is however many messages disappeared.

I say "deleted," in quotes, as the messages are not gone from the server, just from Thunderbird.  If I quit out of the program and re-launch, the messages are slowly reloaded.  

Reproducible: Sometimes

Steps to Reproduce:
1. Compose new mail message, or reply, or forward....
2. Click send

Actual Results:  
Brief hang on "copying message to sent folder" (progress bar stops moving).  Then, message appears sent, and Thunderbird reports that it "Deleted xxxx messages."  They disappear from the list, but are still on the server.  Most recently, it deleted 1410 messages, making the most recent message in my inbox from 2008/11/04.  

Expected Results:  
Well, the message gets sent, is copied to the sent messages folder, and my inbox stays how it was before.

IMAP Log immediately after sent message:

-1332527104[17ba8d00]: ReadNextLine [stream=1ae4aa08 nb=29 needmore=0]
-1332527104[17ba8d00]: 1d2ec00:10.1.1.11:S-INBOX:CreateNewLineFromSocket: 4 NO FETCH unexpected event
-1329864704[17bf9300]: 1edfc00:10.1.1.11:A:SendData: 
-1329864704[17bf9300]: ReadNextLine [stream=1bb325d8 nb=46 needmore=0]
-1329864704[17bf9300]: 1edfc00:10.1.1.11:A:CreateNewLineFromSocket: 3 OK [APPENDUID 1 15640608] APPEND completed

Using IMAP, messages in  Inbox downloaded for offline use.
Any idea what kind of imap server you are connected to ?
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
Version: unspecified → 1.9.1 Branch
The "Deleted xxx messages" is actually when it removes the message from the sent folder. Not the inbox folder.
(Reporter)

Comment 3

9 years ago
>> Any idea what kind of imap server you are connected to ?

It's a FirstClass groupware server.  I'll ARD into it in a bit and tell you what version of the server is running as well as what version of Internet Services.  

>> The "Deleted xxx messages" is actually when it removes the message from the
>> sent folder. Not the inbox folder.

Well, the messages are disappearing from my Inbox, regardless of what that line is meant to be referring to.  I haven't checked to see if messages are disappearing from sent as well, since I'm having enough problems just getting them to copy TO my sent folder.  However, I can assure you, there are not 1400 messages in my sent folder to delete.  Currently, there are 73 messages in my sent folder.
(Reporter)

Comment 4

9 years ago
As far as I can tell, the FC server is running version 9.1, as is the FC internet services server.  Hard to tell what the build is on the internet services, seems to be B9207.
David would it help to have an account there to debug the issue ?
(Reporter)

Comment 6

9 years ago
I could get an account created for you, but it would be useless.  The server is inaccessible outside our network.

Comment 7

9 years ago
more of the log could be very useful, in particular, the part before the NO response came back from FETCH.
(Reporter)

Comment 8

9 years ago
Created attachment 383465 [details]
IMAP log

This is the most recent portion of my log, including a good number of lines before the most recent occurrence of the issue.  This time, 994 messages were deleted.  Personal information regarding the recipient of my email has been removed.  (name, email.)
(Reporter)

Comment 9

9 years ago
Or rather, I didn't delete her info.  Oh well.  I'm sure she gets plenty of spam, anyway. =P
(Reporter)

Comment 10

9 years ago
Created attachment 383482 [details]
Log - removed 2006 of 2012 messages in my inbox

Seems to be happening consistently when I send a message.  This time it removed 2006 of the 2012 messages that were in my inbox.  These are the lines immediately following my outbound message in the log.
Attachment #383465 - Attachment mime type: application/octet-stream → text/plain
Attachment #383482 - Attachment mime type: application/octet-stream → text/plain

Comment 11

7 years ago
assuming this is invalid, like bug 500180, bug 498960
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.