Last Comment Bug 49862 - Make new bug default to blank priority
: Make new bug default to blank priority
Status: RESOLVED WONTFIX
:
Product: Bugzilla
Classification: Server Software
Component: Bugzilla-General (show other bugs)
: unspecified
: All All
: P5 minor (vote)
: ---
Assigned To: Dave Miller [:justdave] (justdave@bugzilla.org)
: default-qa
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-22 15:16 PDT by leger
Modified: 2012-12-18 20:46 PST (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description leger 2000-08-22 15:16:21 PDT
tara/asa/endico, can we make it so a new bug 
(http://bugzilla.mozilla.org/enter_bug.cgi?) 
auto fills with a blank Priority, not P3 please?  Eng Mgrs are using this field 
a lot more to prioritize work, and when it auto fills with P3 it messes them up.

I will be requesting the same in Bugscape from namachi.

Thanks! -Jan
Comment 1 Dawn Endico 2000-08-22 15:31:55 PDT
There's no such thing as a blank priority. I think it would be a bad idea to 
invent one. This is a mozilla.org issue. Assigning to asa
Comment 2 rubydoo123 2000-08-22 18:40:15 PDT
Why would this be bad? The engineer/engineer mgr should be setting the priority. 
With a system default of p3 -- we have no idea if the bug has been evaluated and 
the priority set, or if it was just a default setting -- consequently, a p3 
setting means absolutely nothing, it's bogus -- and that clearly should not be 
the case.
Comment 3 Jesse Ruderman 2000-08-22 20:19:58 PDT
should changing assignee clear the priority as well?
Comment 4 Asa Dotzler [:asa] 2000-08-23 10:53:16 PDT
It seems to me there are plenty of ways to see if the bug has been evaluated.
If the bug has been Accepted, if the bug has a Target Milestone, if the bug has
comments from the Assignee.  Shouldn't the priority be set when the bug is
Accepted and a Target Milestone be set based on that. If that's the case then
any accepted bug with a Priority of 3 it is safe to assume that it has been
triaged as a P3 and not defaulted there.  Maybe I'm missing something...
As far as how to do it, there currently isn't a -- value for that field so would
this have to be a change to the core bugzilla code and then updated at
particular instalations?
Comment 5 rubydoo123 2000-08-23 13:34:18 PDT
ok, so I look at the milestone, I look at assigned to, I look at the comments, I 
look at the status, I look at whatever -- which one of those is a hands down 
guarantee that the priority is really a p3 or whether it was an 
oversight? Convince me on that one, and I 'll gladly drop the request.

What am I missing? What is the issue? The -- is available under milestone 
selection, so it isn't like this is a new phenomena.

Comment 6 Asa Dotzler [:asa] 2000-08-23 14:08:12 PDT
it's not as easy as flipping a switch from defaulting P3 to defaulting --.  
There is no unset -- item to defualt to.  I'm not going to argue that it 
shouldn't happen, I'm just suggesting that until it does we're not completely 
blocked from using Priority.  I guess this is a bug in Bugzilla and not a bug in 
our installations.  So should this go to tara?
Comment 7 leger 2000-08-23 16:29:53 PDT
Yes...assigning to tara.  My understanding is that the priority field is used 
for engineers (both internal and external) to order they work load.  Having it 
default to blank is very good.  Otherwise, they can never use P3.  It won't ever 
be correct since all new bugs default to this.

Make sense?
Comment 8 Jacob Steenhagen 2001-01-02 10:23:46 PST
Unless I'm mistaken, this has already been fixed on bugzilla.mozilla.org and is
a config issue, not a code issue...
Comment 9 Asa Dotzler [:asa] 2001-01-02 10:31:34 PST
this is a config issue and has been FIXED for bugzilla.mozilla.org
Comment 10 Matthew Tuck [:CodeMachine] 2001-01-13 08:10:20 PST
I'm reopening this as I'd like to see the default bugzilla installation ship
with a '---' priority.  I think it's the right thing to do.
Comment 11 Jacob Steenhagen 2001-01-13 10:05:47 PST
Making this the default is an easy patch... I should be able to do it Monday 
(unless someone beats me to it).  It's a quick change to checkconfig.pl and 
defparams.pl.

Please Note, this will change the default for new installs, but not for 
old/established ones.
Comment 12 Jesse Ruderman 2001-01-13 15:34:28 PST
Will there be instructions for people upgrading on how to change it to --- by 
default if they want to?
Comment 13 Matthew Tuck [:CodeMachine] 2001-01-13 18:37:31 PST
We could release note it, saying how to do it and explaining why we think it's a
good thing.
Comment 14 Jacob Steenhagen 2001-01-13 21:29:47 PST
It's an easy process... we could do various things I guess... release note it, 
post it in the NG have ./checksetup say something about it...

 1) Edit localconfig and change:
    > @priorities = (
    >         "P1",
      - To -
    > @priorities = (
    >         "--",
    >         "P1",
 2) Go to Edit params and change the "defaultpriority" to "--"
Comment 15 Matthew Tuck [:CodeMachine] 2001-01-13 21:34:08 PST
I don't think we should automatically do it.  Some people might want it
otherwise.

Should we enforce what we consider to be good practice?  Maybe.

But if we allow the '---' to be removed, then we shouldn't force it to be
added.  If we prevented if from being removed, it'd be another matter.
Comment 16 Jacob Steenhagen 2001-01-13 22:02:01 PST
Absolutely.  I see no problem on making it the default for new installs.  I 
also see no problem with recommending it for existing installs (and providing 
instructions for making the change), but I do see a problem with forcing the 
change.

Question: Is there even a "release notes" for bugzilla?
Comment 17 Tara Hernandez 2001-01-13 22:13:08 PST
This is lot of discussion for something that's already 100% configurable and 
really a site-specific usage issue.  Please to be leaving the defaults alone.  

For the record, Bugzilla doesn't have release notes, but extending README is the 
next best thing.
Comment 18 Matthew Tuck [:CodeMachine] 2001-04-16 05:15:58 PDT
There will be no verification from me here until Tara explains why the new
installation defaults shouldn't be changed.
Comment 19 Dave Miller [:justdave] (justdave@bugzilla.org) 2001-09-15 02:16:06 PDT
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE

Note You need to log in before you can comment on or make changes to this bug.