Thunderbird uses 100% cpu + 500mb of ram on startup

RESOLVED WORKSFORME

Status

Thunderbird
General
--
critical
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: ryan.m.monroe, Unassigned)

Tracking

({perf})

Trunk
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99 GTB5 (.NET CLR 3.5.30729)
Build Identifier: version 2.0.0.21 (20090302)

Thunderbird worked fine until I added accounts for gmail and windows live.  Upon adding them, whenever thunderbird starts, it eats up all of my available CPU power, and swells to anywhere from 300mb to ~800mb.  It shifts between these values very rapidly, going from the lowest to highest faster than task manager can follow.  While this is happening, the green bar in the bottom right cycles to show you thunderbird is doing something.

Initially, removing the gmail account solved the problem.  If thunderbird was in the infinite loop when I removed the account, it returned to working normally.  If I added another gmail accound (either by selecting the Gmail option, or entering the settings manually as a POP or IAMP account), thunderbird worked normally until I restarted it, at which point it would happen again.  After trying many variations of the account setups, the same bug has begun to happen even when there are no accounts on my system other than the initial comcast account.

This bug occurs in both Thunderbird 2.0.0.21 and 3.0b2.

Reproducible: Always

Steps to Reproduce:
1.  Add gmail to Thunderbird
2.  Close Thunderbird
3.  Open Thunderbird
Actual Results:  
Thunderbird opens, and eats ~100% CPU as well as 300-800mb of ram.

Expected Results:  
Thunderbird opens normally

Comment 1

9 years ago
a) are you using the newest version of webmail extension?
b) can you try ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-1.9.1/
   and report results? backup your profile first
Keywords: perf
Version: unspecified → Trunk
(Reporter)

Comment 2

9 years ago
Sorry for the late reply guys, the nightly build did work for me.  I recently upgraded to windows rc7 though, and it works fine there too.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Fixed is when we know what fixed the bug. I your case Works for me is better suited.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.