cannot attach files with Japanese names in any directory other than Windows Desktop

CLOSED WORKSFORME

Status

MailNews Core
Internationalization
P3
normal
CLOSED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Gary Liu, Assigned: nhottanscp)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When composing a message with a Japanese attachment, the Japanese file can be
successfully attached only when it is on the Windows desktop. When the files are
in other directories, they are not attached and no error is produced.

observed with 2000-08-18-08M18 build under JA Win98

Steps to reproduce:
1. Create a file with a Japanese name on the desktop (I used ????????.txt)
2. In NS 6 go to File->New->Message
3. In composer window, go to File->Attach File
4. Select the file on the desktop. It should be attached now.
5. Copy the file to any other directory (I used the root directory)
6. Try attaching the file again

Expected result: the file should be attached
Actual result: nothing is attached.

Comment 1

18 years ago
Confirming the bug with 8/21/2000 Win32 build also.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
Apparently this has been broken for some time.
I can see this problem with 8/8/2000 Win32 build.

Comment 3

18 years ago
nhotta is on vacation for a few days.
Rich, can you help?
(Assignee)

Comment 4

18 years ago
Does this works on PR2 and broken in M18?

Comment 5

18 years ago
Yes for PR2. 
This is a regression that happened under M18.
(Assignee)

Comment 6

18 years ago
cc to alecf@netscape.com,ducarroz@netscape.com.
putting nsbeta3 keyword
Keywords: nsbeta3
(Reporter)

Comment 7

18 years ago
It seems to be working on the 2000-08-23-08M18 win32 build now.
changing to worksforme
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 8

18 years ago
To guangyan for verification.
QA Contact: momoi → guangyan
(Reporter)

Comment 9

18 years ago
verified on 2000-08-25-04M18 build under JA win98
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

18 years ago
closing bug
Status: VERIFIED → CLOSED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.