Crash [@ nsDocLoader::Stop]

RESOLVED WORKSFORME

Status

()

Core
DOM
--
critical
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows XP
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

9 years ago
I have this unminimized testcase that crashes this way:

http://crash-stats.mozilla.com/report/index/de014c23-6006-4bcd-9b40-0d9432090616?p=1
0  	xul.dll  	nsCOMPtr_base::assign_with_AddRef  	 obj-firefox/xpcom/build/nsCOMPtr.cpp:88
1 	xul.dll 	nsDocLoader::Stop 	uriloader/base/nsDocLoader.cpp:300
2 	xul.dll 	nsDocShell::Stop 	docshell/base/nsDocShell.cpp:3975
3 	xul.dll 	nsDocShell::InternalLoad 	docshell/base/nsDocShell.cpp:7955
4 	xul.dll 	nsDocShell::LoadURI 	docshell/base/nsDocShell.cpp:1351
5 	xul.dll 	nsLocation::SetURI 	dom/base/nsLocation.cpp:316
6 	xul.dll 	nsLocation::SetHrefWithBase 	dom/base/nsLocation.cpp:590
7 	xul.dll 	nsLocation::GetSourceBaseURL 	dom/base/nsLocation.cpp:928

It doesn't seem to crash in Firefox3.0.11.
(Reporter)

Comment 1

9 years ago
This seems to have regressed between 2009-06-15 and 2009-06-16:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2009-06-15+04%3A00%3A00&enddate=2009-06-16+06%3A00%3A00
My guess a regression from bug 498319.
Blocks: 498319
Keywords: regression

Comment 2

9 years ago
Any chance to get the testcase? If bug 498319 caused this, it sounds like it
just revealed some existing bug.
(Reporter)

Comment 3

9 years ago
I'm sorry, I haven't been able to get a minimized testcase yet.
I could give you the unminimzed testcase, if you want? But I'd rather mail that directly, since it's huge.
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsDocLoader::Stop]
You need to log in before you can comment on or make changes to this bug.