Closed Bug 498743 Opened 11 years ago Closed 11 years ago

No mouseover highlighting set for toolbar buttons when show "text" mode is enabled

Categories

(Firefox :: Theme, defect, minor)

3.5 Branch
All
macOS
defect
Not set
minor

Tracking

()

RESOLVED WONTFIX

People

(Reporter: MattN, Unassigned)

References

()

Details

(Whiteboard: [FFT3.5])

On Mac OS X, navigation toolbar buttons look very plain in text-only mode and the buttons do not change colour on mouseover as expected in litmus test case 6038.

The issue does not occur on Windows or Linux.

Steps to reproduce:
1. View -> Toolbars -> Customize
2. Change the "Show:" dropdown to "Text"
3. Click "Done"

Actual Results:
Icons are not shown.  Putting my mouse over one of the navigation buttons (ie. back, forward, reload, etc.) does not change the style on the button

Expected results:
On mouseover of one of the navigation buttons the button should be highlighted as it is on Windows/Linux.
Hardware: x86 → All
Adding [FFT3.5] in whiteboard.  Came across this issue during RC1 testing
Whiteboard: [FFT3.5]
Alex, the current behavior is not intended, or? Personally I have to agree that a hover state should be used like on other platforms.
Flags: in-litmus?
Keywords: uiwanted
Summary: No mouseover highlighting when toolbars set to "text" mode → No mouseover highlighting set for toolbar buttons when show "text" mode is enabled
Current behavior is intended, there aren't any apps on OS X that use a hover behavior, even for text+icons (like the iWork apps).
Keywords: uiwanted
Thanks Alex. That makes this bug WONTFIX.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.