Incompatibility between auto-complete and search from address bar

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
19 years ago
14 years ago

People

(Reporter: svassall, Assigned: hangas)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build no: 2000082106 (Linux)

There seems to be an incompatibility between having auto-complete in the address
bar and allowing it to used for searching. Say I have visted site news.gnome.org
and I want to search for news the autocomplete widget will complete when I type
in news to news.gnome.org. I cannot search from the address bar for news alone,
only search for news.gnome.org.

This could be retified by making the search button only search on what has been
typed in.

To repeat,
1. Vist site news.gnome.org
2. Type in news. in the address bar
3. Completetion to news.gnome.org occurs
4. Cannot search for news using the search button, only news.gnome.org

Comment 1

19 years ago
Reassigning from bdonohoe to hangas
Assignee: bdonohoe → hangas

Comment 2

18 years ago
 One can avoid this by the odd dance of hitting space to cancel and clear out
the autocompletion -- assuming that this doesn't autocomplete something else --
and then hitting backspace to delete the space you just introduced. But this is
irritating, and not all that obvious to a normal user (I had to experiment to
convince myself that it wouldn't just autocomplete it again).

 Filling in the autocompletion in the URL bar has a number of unhappy
consequences, this among them in my opinion. The other obvious consequence
is that it is difficult to paste in something if your prefix is going to be
autocompleted. For example, suppose you have a shortcut to Bugzilla lookups
and want to do a query from a bug number just reported on IRC. You type 'bz ',
which is promptly autocompleted to some bug number, and now you have to space,
backspace to get something you can paste into.

 Certainly if there are multiple possible completions it would be nice if
Mozilla did not fill in the URL bar with a random one, just give you a choice
off a drop-down.
cannot reproduce 2000110304.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
Chaning the qa contact on these bugs to me. MPT will be moving to the 
owner of this component shortly. I would like to thank him for all his hard 
work as he moves roles in mozilla.org...Yada, Yada, Yada...
QA Contact: mpt → zach

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.