Closed Bug 498787 Opened 11 years ago Closed 9 years ago

Printing Background Colors still prints even when option is unchecked

Categories

(Core :: Printing: Output, defect, minor)

1.9.1 Branch
x86
macOS
defect
Not set
minor

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: tchung, Unassigned)

References

()

Details

(Whiteboard: [FFT3.5])

Attachments

(1 obsolete file)

It seems that unchecking "Print Background Colors" will still print the page with background colors.   Tested at the URL.

Repro:
1) load any 1.9.1nightly or Firefox 3.5 rc1 build
2) go to url, or any site with a background color other than white
3) File > Print, uncheck "Print Background Colors"
4) Click Preview to verify no background colors are shown (its white)
5) Print the page
6) Verify background colors continue to print out.  (blue-gray)

Tested on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090612 Firefox/3.5
Adding [FFT3.5] in whiteboard.  Came across this issue during RC1 testing
Whiteboard: [FFT3.5]
Attached file non-testcase (doesn't reproduce bug) (obsolete) —
Tony, can you check whether you see the bug on this simple testcase?
Also, if you haven't already, can you double-check that you see this in a fresh profile as well?  (It's feasible that this could be caused by odd/stale configuration in about:config)

FWIW, I can't reproduce this on Linux mozilla-central.  Likely to be Mac-only.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090614 Minefield/3.6a1pre
(In reply to comment #3)
> Also, if you haven't already, can you double-check that you see this in a fresh
> profile as well?  (It's feasible that this could be caused by odd/stale
> configuration in about:config)
> 
> FWIW, I can't reproduce this on Linux mozilla-central.  Likely to be Mac-only.
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090614
> Minefield/3.6a1pre

Yep, it was on a fresh profile.
(In reply to comment #2)
> Created an attachment (id=383586) [details]
> simple testcase
> 
> Tony, can you check whether you see the bug on this simple testcase?

1) Test print with "print background" UN-checked:  
Result: No background color printed.

2) Test print with "print background" checked:  
Result: Light gray background color printed.
Comment on attachment 383586 [details]
non-testcase (doesn't reproduce bug)

(In reply to comment #5)
> 1) Test print with "print background" UN-checked:  
> Result: No background color printed.

Ok, thanks -- that sounds like this testcase shows expected behavior (no bug).  There must be more factors involved, then...
Attachment #383586 - Attachment description: simple testcase → non-testcase (doesn't reproduce bug)
Attachment #383586 - Attachment is obsolete: true
I see this in Windows XP, too. Seamonkey 2.1b2pre nightly build 20101130

More factors: In Preferences->Appearance->Colors, set a non-white background color. Mine is an off-white grayish color and printed pages have a background color regardless of the "print background" setting. Change the background color pref to white and the print preview page background once again becomes transparent/white.

tchung, is this your problem, too?
I'm experiencing the issue that's mentioned in Comment 7. I prefer to use a non-white background color by default, and everything prints with that background color rather than the more obvious white.

Firefox 4.0b8, Mac OS X 10.6.5.
I'm having the same problem since I upgraded to Firefox 4 in the two computers I use (Windows XP and Windows Vista). The background colour is the one I've set as default page background in Preferences.
(In reply to comment #7)
> More factors: In Preferences->Appearance->Colors, set a non-white background
> color.
[...]
> tchung, is this your problem, too?

I'm assuming the answer to this is "no", based this in comment 4:
> "Yep, it was on a fresh profile.")
and also this from comment 0:
> go to url, or any site with a background color other than white

(The color set in the preferences should only come into play for sites that don't specify a background color themselves.  tchung's site, http://sportsillustrated.cnn.com/ , *does* set a background color, so he was experiencing something different.)

Resolving this as WORKSFORME, per comment 5 / comment 6.  tchung, please reopen if you can still reproduce.

I'm filing a new bug on Comment 7,8,9. (the issue with a user-specified custom background color)
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
(In reply to comment #10)
> tchung, please reopen if you can still reproduce.

(And if you can reproduce, it'd be great if you could try to reduce a testcase from http://sportsillustrated.cnn.com/ , since the straightforward reduced testcase (just a page with a background-color) that I created didn't seem to work)
(In reply to comment #10)
> I'm filing a new bug on Comment 7,8,9. (the issue with a user-specified custom
> background color)

(filed Bug 652914)
You need to log in before you can comment on or make changes to this bug.