With wireless network connection, offline mode randomly switches on

RESOLVED DUPLICATE of bug 509400

Status

()

RESOLVED DUPLICATE of bug 509400
9 years ago
8 years ago

People

(Reporter: jules, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10

When resuming Windows from hibernation with firefox running and a wireless network connection that sometimes takes about 10 seconds after the system is running again to reconnect, firefox randomly switches to offline mode about one time in ten.

Reproducible: Sometimes

Steps to Reproduce:
1. Connect to the Internet via a wireless network with a slow access point.
2. Start firefox
3. Hibernate
4. Wait long enough for connection to have dropped (I don't know how long this is, but it seems to be a significant length of time)
5. Resume from hibernation.
Actual Results:  
Sometimes, the "work offline" mode is enabled.

Expected Results:  
The "work offline" mode should remain in the same state as I left it the previous day.

Comment 1

9 years ago
Is the problem mitigated by the following extension?
https://addons.mozilla.org/en-US/firefox/addon/13152

Comment 2

9 years ago
I just wanted to file a bug record. I have just the same effect. Some times after returning from hibernating, Firefox is switched to Offline Mode since my WLAN is not yet connected when Firefox gets CPU time first time again.
This is annoying since you don't realize it. I just refresh a certain web page to see if there is news but I don't see that it comes from cache.
I hope you really fix this. An addon is just an odd workaround.
I never use offline mode; I wish you introduced an option to disable this automatism of offline switching.
Reporter, please retest with Firefox 3.6.12 or later in a fresh profile (http://support.mozilla.com/kb/Managing+profiles). Also update your plugins (flash, adobe reader, java, quicktime, silverlight, etc.) Go to the developer's website and download the latest version from there. If you no longer see this issue, please close this bug as RESOLVED, WORKSFORME. If you do see the bug, please post a comment.
Whiteboard: [CLOSEME 2010-12-01]
(Reporter)

Comment 4

8 years ago
Still happening with 3.6.12.
Whiteboard: [CLOSEME 2010-12-01]
Please try firefox 4 beta 7. There have been several improvements to offline mode when waking from hibernation.
Version: unspecified → 3.6 Branch

Comment 6

8 years ago
For me ok since several 3.x versions. My WLAN hardware is still the same.
But I'm running on Windows 7 since about 9 Month - maybe return from hibernate has different timing there.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 509400
You need to log in before you can comment on or make changes to this bug.