large textarea takes 100% of CPU on reload

VERIFIED FIXED

Status

()

P2
major
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: peterlubczynski-bugs, Assigned: anthonyd)

Tracking

({perf})

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-][p:2])

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Start NT's task manager CPU graph so it's visible. Load the testcase. Now reload 
the test case and watch the CPU go up to 100% for quite a while, much longer 
than it took on the first load.
(Reporter)

Comment 1

19 years ago
Created attachment 13307 [details]
testcase with large textarea

Comment 2

19 years ago
->editor
Assignee: trudelle → beppe
Component: XP Toolkit/Widgets → Editor
QA Contact: jrgm → sujay

Comment 3

19 years ago
I would suspect that this has to do with incremental reflow issues -- Anthony, 
can you verify that, and if that is the case, please reassign to layout for 
resolution
Assignee: beppe → anthonyd

Comment 4

19 years ago
adding perf and moving to m19
Keywords: perf
Target Milestone: --- → M19

Comment 5

19 years ago
confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

19 years ago
reviewed by Bijal and beppe, setting to nsbeta3+, p2
Severity: normal → major
Keywords: nsbeta3
Priority: P3 → P2
Whiteboard: [nsbeta3+][p:2]
(Assignee)

Comment 7

19 years ago
okay, on my machine, whether i do a reload, or a shift+reload, the CPU does 
spike to 100% for split second, but then its business as normal.  The funny 
thing is, if I change focus and then change back I get the same spike.

anthony
continuing investigation
Status: NEW → ASSIGNED
(Assignee)

Comment 8

19 years ago
Okay, I need mroe information on this bug.  Blake, you were able to repro this 
on 9-3-2000, is there anymore infor you can give me, how long does it peg the 
cpu?  Without a test case that demonstrates this to me i will have to invalidate 
this bug.

anthony
(Reporter)

Comment 9

19 years ago
I just tried this again and it doesn't seem to be doing the same thing it was
before. Looks like the problem has gone away.

There is something weird now though. Everytime you reload the page, according to
the Task Manager, memory drops by a few k.

Comment 10

19 years ago
*** Bug 47452 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

19 years ago
okay, there must be some sort of misunderstanding, I know very well how to use 
task manager, so I will try again:
1. Do you still see the problem?
2. If yes, how long does it peg the cpu to 100?

Thanks,
Anthony

Comment 12

19 years ago
As currently described, PDT thinks this is an nsbeta3-. We're not signing up to
prevent CPU spikes during program execution. Hangs, yes, but not brief spikes.
Whiteboard: [nsbeta3+][p:2] → [nsbeta3-][p:2]
(Assignee)

Comment 13

19 years ago
Marking this bug as WORKSFORME.
anthonyd
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Bug 48211 (duped to this through 47647 -> 47452 -> this) appears to be fixed now
also.  Typing in textareas seems to be fine now.  Problem went away sometime
late last week.

Comment 15

19 years ago
verified in 9/29 branch build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.