RFE: There should be a bugzilla component for the "Xprint" print system

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
18 years ago
7 years ago

People

(Reporter: roland.mainz, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
As the subject says: RFE for a seperate BugZilla "component" for the X11 print
system in Mozilla would be quite usefull as it is (technically) far different
from the normal postscript-driven print system.
I would file some bugs for it without wasting the time of the "normal " print
gurus.

I would vote for (one of) Masaki Katakai (masaki.katakai@sun.com), Hidetoshi
Tajima (hidetoshi.tajima@sun.com), Kumar Rethi (rethi.kumar@sun.com) or myself
as the default bug owner (unformtunately I cannot add them to CC:).


(Stupid question: Is there a better way where to file such BugZilla for Mozilla
should have a COMPONENT for ... RFEs ?)
(Assignee)

Comment 1

18 years ago
It is fine to file bugs on the current print component and just assign them to
yourself or one of the other names you mentioned. I'm not sure that adding a new
component is necessary. Adding Jan Leger to this discussion.

Component requests should be communicated to me (asa@mozilla.org) and
leger@netscape.com.  A bug filed on Browser General seems to me to be a good way
to request
components.
(Assignee)

Comment 2

18 years ago
Is this bug traffic enough to warrant it's own component?  Is there code in the
tree that this component would cover?
(Reporter)

Comment 3

18 years ago
> Is there code in the tree that this component would cover?

Yes, see mozilla5/M17/mozilla/gfx/src/xprint/
(Assignee)

Comment 4

18 years ago
adding pavlov since he might be interested.  Roland, can you email those folks
and see if any of them are willing to be default owner and qacontact for this
proposed component.  
(Reporter)

Comment 5

18 years ago
> Roland, can you email those folks
> and see if any of them are willing to be default owner and qacontact for this
> proposed component.

I've added them to CC (they used other emails for BugZilla accounts than I used
in the initial report for this "Bug").
(Assignee)

Comment 6

18 years ago
adding lisa chiang and removing jan leger.

Comment 7

18 years ago
Once you guys have decided on the final details of this, let me know and I can
create the component as needed.  Need:  product the component would fall under,
description of the component, default eng owner, default QA owner. It's best to
send me email once this is decided in case this bug notification gets lost in my
list of bug notifications to read.
(Assignee)

Comment 8

18 years ago
another thought.  if we do create this component I think it would be helpful if
it was called "Printing: Xprint" or something like that so it would sho up in
the list next to the Printing component.  kind of like the way XP Toolkit
Widgets does it.

Comment 9

18 years ago
default owner: should be the main person behind the code. Roland - who's writing
the code?


(Assignee)

Comment 10

18 years ago
So, is there anyone on this list that would like to be the component owner and
qa contact?  
(Reporter)

Comment 11

18 years ago
"who wrote this code":  Masaki Katakai (katakai@japan.sun.com), Hidetoshi Tajima
(tajima@eng.sun.com) and Kumar Rethi (rkumar@eng.sun.com)
Question is if one of them likes to be the "default owner"...
(Assignee)

Comment 12

18 years ago
Accepting this bug.  If someone steps forward as Owner and QA contact I will
help get it se up in Bugzilla
Status: NEW → ASSIGNED

Comment 13

18 years ago
Sun will keep owning modules in gfx/src/xprint and will do XPrint integration
into Mozilla, so I'm glad to own the project. Please advise what tasks
are necessary for a new project owner.
Hidetoshi Tajima - asa@mozilla.org can set this up, all we would need is another
person to set as QA contact who can vHidetoshi Tajima 20erify if bugs are
vHidetoshi Tajima fixed/etc.  I could not be it as I do not have a sun box to
test on.
(Reporter)

Comment 15

18 years ago
Any update here ?

(I wish to be able to do the QA job - but unfortunately it seems that I won't
have access to the machines next year - institute is going to be dismantled.
Anyone wanna employ me... ? =:-)

Known Xprint isses:
- Xprint doesn't work on MSB platforms (Solaris SPARC) (this is bug 49879 - and
can be fixed if someone applies the fix described in bug 49879... this is only
one line to change... heeellppp...).
- Xprint doesn't set a document title
- Xprint doesn't set any attributed like color/grayscale, paper size etc. 
- Xprint needs support within the print dialog (more or less same problem as the
line above)

(Assignee)

Comment 16

18 years ago
This can be set up when we have an Owner, a QA contact and a description of the
component.  Until then these bugs can live under the print component and just
get assigned to the person who will be the XPrint owner and they will have the
default Print QA contact.
(Reporter)

Comment 17

18 years ago
QA=roland.mainz@informatik.med.uni-giessen.de (I hope there is an easy way to
change email in all bugs...)
component="Printing: Xprint" (to get some alphabetic order - like "Perferences"
and "Preferences: Backend")
owner=one of
{katakai@japan.sun.com,lchiang@netscape.com,pavlov@netscape.com,tajima@eng.sun.com}
(Assignee)

Comment 18

18 years ago
Roland, what email do you need changed in all bugs?  
(Reporter)

Comment 19

18 years ago
Some day... in far far (!?) future I may change my email address (e.g.
roland.mainz@informatik.med.uni-giessen.de) - I'm not a friend of having tons of
different email addresses - this only confuses people - including myself... =:-)
But the current one is at least stable for the next half year (our institute
here is going to be dismantled next year... ;-( ). Don't be worried - ignore the
comment... :-)
(Assignee)

Comment 20

18 years ago
Just need an owner.  Roland, maybe you should lobby these candidates in email.
(Reporter)

Comment 21

18 years ago
More bugs:
- Mozilla seems to use client-side rendering (or not ?). Maybe good for
performance but bad for Xprint (creates huge output (PS/PCL) files)

----

> Roland, maybe you should lobby these candidates in email.

Mhhh... BugZill normally send people email on changes... any *.sun.com engineer
listing here ?
(Assignee)

Comment 22

18 years ago
updating Product and component.
Status: ASSIGNED → NEW
Component: Browser-General → Bugzilla: Keyword/Component Changes
Product: Browser → mozilla.org
QA Contact: doronr → lchiang
(Reporter)

Comment 23

18 years ago
Send "lobby" email.

----

More bugs:
- Xprint does not set the job title
- Xprint should support "grayscale"/"bw" output
(Reporter)

Comment 24

18 years ago
More bugs:
- Xprint does not wait until images have been loaded
- XP widgets show some visual corruption (this _may_ be bug 9913)

RFEs:
- Xprint should support grayscale printing (AFAIK already implemented, only
requires to replace the #ifdef by if()... :-)
- Xprint should support "preview" mode (same as above)

Lowlights:
- No response from "lobby" email

Comment 25

18 years ago
Roland, I didn't respond to your email (which you sent to me directly) because I
don't have input on whether there is a Xprint component or not.  It looks like
you just need to know who to put down for the owner?  
(Assignee)

Comment 26

18 years ago
I'll create this component sometime this week.  I'm going to put
Roland.Mainz@informatik.med.uni-giessen.de down as qa and tajima@eng.sun.com as
owner (I missed Hidetoshi's comment earlier, sorry). and call it "Printing:
Xprint".  Any objections?

Comment 27

18 years ago
Asa, please wait for another couple of days until
I get this confirmed with others.


(Reporter)

Comment 28

18 years ago
to lchiang@netscape.com:
> It looks like you just need to know who to put down for the owner?
Based on Hidetoshi Tajima's comment "Sun" likes to "own" that code. But because
noone responded to bugzilla's emails I started to look for alternatives... ;-(

I'd simply like to file tons of bugs for the Xprint code and then try to hunt
down&kill these insects...

BTW: I'm going on chrismas vacation this wednesday (20001220) until next year...
I assume the BugZilla component isn't available until then, right ?

Comment 29

18 years ago
Hi, sorry for late response. I (katakai@japan.sun.com) would like to take
this task, component owner for Xprint.
(Reporter)

Comment 30

18 years ago
Fun... first time noone wanted to be the "owner"... now three people want to get
that job... :-))

----

More Xprint bugs/issues:
- RRFE: Xprint should allow to print to file (looks simple - I can write that
:-)
- RFE: Xprint should use env var "XPSERVERLIST" (see
file:/usr/openwin/server/etc/XpConfig/README) instead of "XPDISPLAY" (I can
write that, too)
- BUG: Xprint crashes if server does not support the Xprint extension
- BUG: Xprint crashes if printer cannot be found
- RFE: Print dialog should support Xprint (see below)

----

Print dialog should support Xprint:
AFAIK Xprint supports both file and printer output, therefore Xprint should not
be a 3rd option (e.g. "Printer, File, Xprint"). 
I would vote for a RadioGroup which allows to select between "Print command" and
"X11 print system".
Has anyone time to update 
http://lxr.mozilla.org/mozilla/source/xpfe/global/resources/locale/en-US/unix/printdialog.dtd
,
http://lxr.mozilla.org/mozilla/source/xpfe/global/resources/content/unix/printdialog.xul
and the matching javascript file ?

Comment 31

18 years ago
Hi Roland. let's file bugs for those problems and RFEs first. Once new
category is created, we can move them.

For printing to file, bug 39820 exists. For print dialog, I believe
it's bug 49946.
(Reporter)

Comment 32

18 years ago
Uhm... yes... I remember that there was (long long ago) a bug 49946... :-)
The other one is new for me. Thx !

Anyway... I file the new bugs next year - I'm currently on the way home (term
holidays)...

----

to asa@mozilla.org:
Is there a reason why this bug still has "NEW" status ?

----

Last question (maybe... =:-) for this year:
Is the Xprint code in CVS the current one or do you have newer versions
(because  I'd like to start hacking immediately when I am back in 1.1.2001 ...).

----

Merry chrismas and a happy new year !!
(Assignee)

Comment 33

18 years ago
accepting but
Status: NEW → ASSIGNED
(Assignee)

Comment 34

18 years ago
accepting bug
(Assignee)

Comment 35

18 years ago
I'll create this component when I know who to put down as owner :)
(Reporter)

Comment 36

18 years ago
Happy new year !!

To make it short: Masaki Katakai was the last one who likes to get the "default
owner" for the Xprint component (note: AFAIK it is not required that "BugZilla
component owner == CVS code owner"), I'll do the QAcontact job...

Comments ?
(Reporter)

Comment 37

18 years ago
More Xprint bugs:
- Xprint fails to print example URL (bug 66708)
- Xprint should close connection to Xprt after printing, otherwise a restart of
Xprt will cause Mozilla to exit
(Assignee)

Comment 38

18 years ago
component created.  please check that the description looks OK and that the
component owner and QA contacts are correct before verifying this bug.
<http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser>
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 39

18 years ago
Marking as "verified". Component "Printing: Xprint" is available and works...
:-))
Status: RESOLVED → VERIFIED
Component: Bugzilla: Keywords & Components → Administration
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.