All users were logged out of Bugzilla on October 13th, 2018

[MLK] Leaking a LeafNode (nsCString) in nsCategoryManager::AddCategoryEntry()

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: beard, Assigned: scc)

Tracking

({memory-leak})

Trunk
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
See the blame URL above. If category->find_leaf(aEntryName) returns a non-NULL 
entry and aReplace is true, then the already existing entry will leak. I've seen 
this leak crop up occasionally, but it only happens during autoregistration, and 
I don't always detect it reliably.
*** Bug 49001 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

18 years ago
Created attachment 13320 [details]
leak report showing nsCString leaks.
(Reporter)

Comment 3

18 years ago
This leak shows up when cookie is auto-registered.
(Reporter)

Updated

18 years ago
Keywords: mlk
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 4

18 years ago
Created attachment 13784 [details] [diff] [review]
leak fix patch
(Assignee)

Comment 5

18 years ago
Created attachment 13800 [details] [diff] [review]
my patch fixes the existing comments and doesn't test (since |delete(0)| is guaranteed to work)
(Assignee)

Comment 6

18 years ago
fix checked in with version 1.18 of the file ... though the patch contained tabs, 
I fixed that before checking in.  Thanks, Patrick!
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
please verify

Comment 8

18 years ago
Marking Verified.  Please reopen if problem reoccurs.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XPCOM Registry → XPCOM
QA Contact: leger → xpcom
You need to log in before you can comment on or make changes to this bug.