Trusteer Rapport causes Firefox to crash on certain bank sites [RapportTanzan3.dll@0x10f8]

RESOLVED FIXED

Status

()

Firefox
Extension Compatibility
--
critical
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Cww, Assigned: Ami Schieber)

Tracking

({crash})

3.0 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs Trusteer to debug using stack traces from Socorro], URL)

(Reporter)

Description

9 years ago
Trusteer Rapport: Financial Malware Prevention from http://www.trusteer.com/product causes users of Firefox to crash on some banking sites. Unfortunately, this software is being recommended (provided?) by some banks in the UK to protect their customers online.

https://support.mozilla.com/tiki-view_forum_thread.php?locale=lt&comments_parentId=367750&forumId=1 for one such forum thread.

See: http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=contains&query=RapportTanzan3.dll&date=&range_value=1&range_unit=weeks&do_query=1&signature=RapportTanzan3.dll%400x10f8 for crash reports.
(Assignee)

Comment 1

9 years ago
Hello,

Trusteer is very interested to debug and fix the problem you've encountered.
Can you describe the scenario that leads to it or contact us at support@trusteer.com ?

We would appreciate your assistance with reproducing the problem so we can fix it as soon as possible.

Thank you,

Ami Schieber
Trusteer Support 
ami.schieber@trusteer.com

Comment 2

9 years ago
ami, we don't have any specific way to find the customers who have this problem, but if you follow the query link from comment 0, you should be able to find enough information to do some basic debugging.

http://crash-stats.mozilla.com/report/index/614a0054-3efb-4275-8369-796832090615
Crash Address	0x0
User Comments	I was exiting Mozilla browser, and Firefox crashed. This keeps happening normally when I start Mozilla or Thunderbird email. Either of these can crash Firefox which I almost always have running. It is only recently this has been happening, maybe since a firefox upgrade. It did not happen in the same circumstances previously.
Processor Notes 	

it sounds like you've unloaded a module...

Frame  	Module  	Signature [Expand]  	Source
0 		@0xa9526b6 	
1 	RapportTanzan3.dll 	RapportTanzan3.dll@0x10f8 	
2 		@0x71450044 	
3 	user32.dll 	DoCallback 	
4 	user32.dll 	ProcessRegistrationMessage 	
5 	user32.dll 	SetMenuItemInfoStruct 	

rooksbas.dll  	2.13.0.0  	B8488A291EFC4473A38DD6E95C299B851  	rooksbas.pdb
rookscom.dll 	2.6.0.0 	5EA6E8F819AF4814B9D177B05C1571E31 	rookscom.pdb
rooksdol.dll 	2.15.0.0 	4FBAD726FBC04B7D8DDF8788C5A46D441 	rooksdol.pdb
RapportTanzan3.dll 	3.5.904.38 	91AA61E2984F4EE58A3693FBA5697F001 	RapportTanzan3.pdb
RapportUtil.dll 	3.5.904.38 	C477DAB53B974925873436D53438B3341 	RapportUtil.pdb

you should be able to find the symbols for these dll's and look up the address to see what it's calling. you can use:
https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
to get symbols for firefox/windows and integrate it with symbols for your code.
Assignee: nobody → ami.schieber
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Keywords: qawanted
Whiteboard: [needs Trusteer to debug using stack traces from Socorro]
(Assignee)

Comment 3

9 years ago
We believe the problem was resolved in our latest versions.
If someone still encounters this issue, please contact support@trusteer.com or download Rapport latest version and see if the problem still occurs.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

9 years ago
Do you have a way to push updates to your users?  If so, can we blocklist the crashing versions?
You need to log in before you can comment on or make changes to this bug.