autocomplete not working with middle-click-opened tabs

RESOLVED DUPLICATE of bug 424646

Status

()

RESOLVED DUPLICATE of bug 424646
10 years ago
10 years ago

People

(Reporter: evilpotatoe, Unassigned)

Tracking

3.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11

When you open a new tab with a middle click on home/bookmark/history, the autocomplete list doesn't appears. You may type something, or use down arrow.. nothing happens.
If you focus anything else and click back to the field, you get back your autocomplete suggestions, without further problem.

note : This usually only happens to me on google/GMail, but I guess it's just because I don't have any other website with an already-focused-field-on-open.
I often encountered this problem when opening new google (my home) tabs, since ff 1.5 but understood it only today, as the cause was all but clear to me.


 * I'm using firefox 3.0.11 (with tab mix plus 0.3.7.3 and flashblock, but the bug appears on another PC without thoses add ons.)
 * I'm running windows (seven beta and RC1 atm, but was the same under XP)
 * I turned off google's suggestions, as they are not compatible with autocomplete, but I discovered that google's suggestions DO work in newly-opened-tabs !
 * Of course, I have "autocomplete" turned ON

Reproducible: Always

Steps to Reproduce:
1.Define google/GMail as home, or bookmark it, or just get it in your history (or maybe even elsewhere)
2.turn off google's search suggestions and be sure you got autocomplete turned on
3.open a new tab on google by clicking on your home/bookmark/history -> you cant use autocomplete ! (in fact, you can.. if you focus something else, then, click back on the main field... argh!)
Actual Results:  
You can't use that damn autocomplete !

Expected Results:  
You would like to use it !

 *I'm not sure this bug doesn't happens in other cases, e.g. when opening a bookmark directory, I didn't think to all possible cases.
 *THIS BUG **** ME OFF !!! (sorry, couldn't hang longer, I'm suffering since severals years now !)
 *My english might suck hard, sorry again


Not using any theme, and only the 2 add-ons I already described.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424646
(Reporter)

Comment 2

10 years ago
Damn !! I checked pages of several keywords before posting it '-.-

Sry for duplicate.
You need to log in before you can comment on or make changes to this bug.