Firefox writes files in profile till disk is full

VERIFIED DUPLICATE of bug 493374

Status

()

Toolkit
Places
--
critical
VERIFIED DUPLICATE of bug 493374
9 years ago
9 years ago

People

(Reporter: Timo Witte, Unassigned)

Tracking

1.9.1 Branch
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/530.5 (KHTML, like Gecko) Chrome/2.0.172.31 Safari/530.5
Build Identifier: 3.5 Beta 4

When i start firefox it behaves extremly unresponsive and writes a lot of files to my profile in.
C:\Users\Spacy\AppData\Roaming\Mozilla\Firefox\Profiles\7f5f77qo.default

places.sqlite.corrupt
places.sqlite-1.corrupt
places.sqlite-2.corrupt
places.sqlite-3.corrupt
places.sqlite-4.corrupt
places.sqlite-5.corrupt
.
.
.
places.sqlite-118.corrupt

the files are all writen in just 1 start of firefox. not 1 file per start! I think this behaviour is extremly bad, because it only stops / hangs when my disk is full.. It should give up after one try create a new file and inform the user or try to repair the file just once!

Reproducible: Always

Steps to Reproduce:
1. Start Firefox
Actual Results:  
System is unresponsive and disk is full after ~2 min in my case.

Expected Results:  
It should give up after one try create a new file and inform the user or try to repair the file just once!

If you need it can upload my places.sqlite file but it´s 200 MB in size (have webserver)
(Reporter)

Updated

9 years ago
Flags: blocking-firefox3.5?
Version: unspecified → 3.5 Branch

Comment 1

9 years ago
I installed firefox 3.5 beta 4 a while ago and had it update itself successfully a few days back.

Then yesterday it tried to update again and quickly failed.  Attempting to run firefox after that gave a 'bus error'.  It appears the disk was full when the update ran, presumably causing the problem.

Checking the disk, it's full of places.sqlite-<nn>.corrupt files, all identical to my places.sqlite file.

I removed the filefox 3.5 beta install and re-extracted the 3.5 beta 4 tarball I had originally downloaded.  While firefox is running, it creates a new places.sqlite-<nn>.corrupt file every 15 seconds until the disk is full.  While this is happened my bookmarks and history are unavailable.

Switching back to firefox 3.0 seems to fix the problem.  My bookmarks and history are available again.

I guess I shouldn't be using the same profile between the two versions - is that right?
(Reporter)

Comment 2

9 years ago
i undestand that i am posting my own personal history and bookmarks here but i have uploaded the corrupt file:

http://files.spacefish.biz/places.sqlite

it´s 208 MB in size so be patient till it´s uploaded completely 25 minutes remaining *g*

Comment 3

9 years ago
http://kb.mozillazine.org/Locked_or_damaged_places.sqlite tells me:

Note: Starting in Firefox 3.5, if you open Firefox and the Places database is locked you will see the message, The bookmarks and history system will not be functional because one of Firefox's files is in use by another application. Some security software can cause this problem

but I didn't see that message at all.
(Reporter)

Comment 4

9 years ago
@#3 this is not the problem right here, because the file isn´t locked it´s marked corrupt by firefox, so it´s possible to open it, otherwise firefox would´nt have opened it, because the other application set a write/read lock on system basis.
(Reporter)

Comment 5

9 years ago
upload of file is complete
you problem is that you was on 3.5b99 and you installed 3.5b4. since the two places databases are unfortunatly not compatible, it started generating all of those files.
Updating to latest RC and deleting all .corrupt files should solve the problem.

Updated

9 years ago
Component: Places → Places
Flags: blocking-firefox3.5?
Product: Firefox → Toolkit
QA Contact: places → places
Version: 3.5 Branch → 1.9.1 Branch

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 493374
ps: you can remove your places.sqlite since we don't need it to debug this issue.

Also, do you use Google Toolbar by chance?
(Reporter)

Comment 9

9 years ago
actually marco bonardo´s solution doesn´t help. It creates the files again!
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Updated

9 years ago
Flags: blocking1.9.1?
notice you must use Help/Check for Updates and upgrade there
Stop asking blocking and don't change bug resolution please.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Flags: blocking1.9.1?
Resolution: --- → DUPLICATE
Duplicate of bug: 493374

Updated

9 years ago
Status: RESOLVED → VERIFIED

Comment 14

9 years ago
(In reply to comment #6)
> Updating to latest RC and deleting all .corrupt files should solve the problem.

Is there any way to keep my history?

I went back to using firefox 3.0 with the same profile, and it's all present and correct there, so the data hasn't been lost.
You need to log in before you can comment on or make changes to this bug.