If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Highlight all" search should use different colour for each distinct search term

RESOLVED INVALID

Status

()

Toolkit
Find Toolbar
--
enhancement
RESOLVED INVALID
8 years ago
2 years ago

People

(Reporter: Lewis Thompson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9.1b2) Gecko/20090223 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9.1b2) Gecko/20090223 Firefox/3.1b2

Using the full search bar (^F):

- search for a term and selecting highlight all marks the matches with a given colour
- search for another term and selecting highlight all marks the matches with the same colour

It would be helpful if each subsequent search used a unique highlight colour to more easily distinguish from other search terms

Reproducible: Always



Expected Results:  
It would be helpful if each subsequent search used a unique highlight colour to more easily distinguish from other search terms

Updated

8 years ago
Component: General → Find Toolbar
Product: Firefox → Toolkit
QA Contact: general → fast.find

Comment 1

8 years ago
I don't think this make much sense, since the result of the first search won't be show at the second time, how come we need to distinguished them?
(Reporter)

Comment 2

8 years ago
Are you sure?  I've definitely had multiple search terms highlighted at the same time.  Maybe it's a bug.
(In reply to Lewis Thompson from comment #2)
> Are you sure?  I've definitely had multiple search terms highlighted at the
> same time.  Maybe it's a bug.

Very sure. If you highlighting for different search terms at the same time, please feel free to file a new bug!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.