Downloads window uses POSIX path to track downloaded files

VERIFIED DUPLICATE of bug 393659

Status

VERIFIED DUPLICATE of bug 393659
10 years ago
10 years ago

People

(Reporter: me+camino, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_6; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1
Build Identifier: Version 1.6.7 (1.8.1.21 2009032711)

In Safari, when you download a file the downloads manager's functionality (Open, Show in Finder) continues to work if a file is moved from the location it's downloaded to. In Camino, if a downloaded file is moved Camino can no longer open the file/move to trash/etc.

Since Camino is aiming to integrate with Mac OS X and utilize OS X technologies to it's advantage, using aliases in the download manager would be an excellent move to integration.

Please understand, I'm not asking for the Camino download manager to act just like Safari's. I'd just like it to be able to track moved files for a more seamless experience.


Reproducible: Always

Steps to Reproduce:
1. Download a file
2. Move or rename the file in Finder
3. Attempt to Show in Finder or Open from download manager
4. Note that Camino is unable to locate the file
Actual Results:  
Camino shows a generic icon for the file and is no longer able to perform any actions on it from the downloads manager

Expected Results:  
Camino should be able to track the file through moves and/or renames, as this is functionality that Mac OS X provides

Some discussion on a similar bug in Preview.app: http://www.drunkenblog.com/drunkenblog-archives/000682.html

Information on Alias Manager, which can be used to implement this functionality: http://developer.apple.com/documentation/Carbon/Reference/Alias_Manager/Reference/reference.html

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 393659

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.