CC list doesn't stay shown when hitting back button in IE 7

RESOLVED DUPLICATE of bug 453932

Status

()

Bugzilla
User Interface
--
minor
RESOLVED DUPLICATE of bug 453932
9 years ago
8 years ago

People

(Reporter: Eric Black, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.10) Gecko/2009042523 Ubuntu/8.10 (intrepid) Firefox/3.0.10
Build Identifier: v3.2.3

This is not a problem with Firefox, but with IE7, if you enter a invalid entry in the 'Add' input box of the CC list after expanding it, then hit commit, get the error page, and hit the back button, the CC list is again hidden with the bad value still in the 'Add' input box. This is an inconvenience, especially if you have multiple things that need to be changed and you forgot about the CC value.

This doesn't happen with all hide/show edit fields, like 'Assigned To:' and 'QA Contact:'.

Reproducible: Always

Steps to Reproduce:
1. Click the 'edit' link (triggers action).
2. Enter a value in the 'Add' that will be invalid.
3. Click commit. The submitted page returns an error that the value is invalid.
4. Click the back button. 

Actual Results:  
The cc list is hidden again with the invalid entry

Expected Results:  
The cc list should be shown with the invalid entry

It looks like the way that IE and Firefox handle the back button is different. With Firefox, it displays everything as it was last viewed. With IE, it does a partial rendering.
(Reporter)

Comment 1

9 years ago
Created attachment 383966 [details] [diff] [review]
Patch to fix the IE back button problem

The attachment is a patch required to fix the problem.

Comment 2

8 years ago
Does it work in IE8? If so, this is a lot of code to fix a problem that's pretty small, and I'd rather just tell people to upgrade if it bothers them.

(BTW, if you want somebody to look at the patch, you'll want to follow our development process, here: http://wiki.mozilla.org/Bugzilla:Developers)
(Reporter)

Comment 3

8 years ago
I don't have access to IE8 yet, so I'm not sure. I agree it's a minor annoyance, but I thought it was better to report the problem than not and if someone else wants to fix their instance, they could see what I had to do.
Checked with this bug using Windows 7 and IE8, same result as described in orginal comment.

IE8 behaves the same as IE7 in this respect. IE7/8 changed the handling of JavaScript history by flushing it more aggresively, it's a "security enhancement". IE6 was more inline with FireFox history wise.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 453932
You need to log in before you can comment on or make changes to this bug.