Ignored autocomplete="off" form

RESOLVED DUPLICATE of bug 418288

Status

()

Toolkit
Form Manager
RESOLVED DUPLICATE of bug 418288
9 years ago
9 years ago

People

(Reporter: Willem Bartels, Unassigned)

Tracking

1.9.0 Branch
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-GB; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-GB; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)

A form with autocomplete="off" will be ignored when
it is echoed from a JavaScript document.write see "Steps to Reproduce".



Reproducible: Always

Steps to Reproduce:
When the second time filling in the username a password will be suggested.
This shouldn’t happen because: autocomplete="off"

<script type="text/javascript">
document.write('<form autocomplete="off">');
document.write('Username: <input type="text" name="username"><br>');
document.write('Password: <input type="password" name="password"><br>');
document.write('<input type="submit">');
document.write('</form>');
</script>
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 222367
Status: RESOLVED → UNCONFIRMED
Component: General → Form Manager
Product: Firefox → Toolkit
QA Contact: general → form.manager
Resolution: DUPLICATE → ---
Version: unspecified → 1.9.0 Branch

Comment 2

9 years ago
What happens if that's just on the password element? i.e:
document.write('Password: <input type="password" name="password" autocomplete="off"><br>');
(Reporter)

Comment 3

9 years ago
(In reply to comment #2)
> What happens if that's just on the password element? i.e:
> document.write('Password: <input type="password" name="password"
> autocomplete="off"><br>');

A autocomplete form must have at least two input field, otherwise there is nothing to complete.
This is almost certainly a dupe of 418288.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 418288
You need to log in before you can comment on or make changes to this bug.