tweak default UI for vertically-challenged devices

VERIFIED FIXED

Status

()

Firefox
General
P2
normal
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: vlad, Assigned: zpao)

Tracking

Trunk
ARM
Windows CE
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nv])

Attachments

(1 attachment, 3 obsolete attachments)

We need a patch to tweak the default UI for vertically-challenged devices; I've no idea where these changes live.

The changes should be:

  - bookmarks toolbar hidden by default
  - statusbar hidden by default
  - toolbar uses small icons by default
Created attachment 384014 [details] [diff] [review]
Patch v0.1

This could probably be cleaned up & we can probably just set the iconsize on the toolbox & take out the places where the iconsize is explicitly set. Dao would know better.

Unless I missed something this makes sure all the checkboxes match up with what the user sees.
(In reply to comment #0)
> The changes should be:
> 
>   - bookmarks toolbar hidden by default
>   - statusbar hidden by default
>   - toolbar uses small icons by default

How about hiding the tab bar when there's only one tab (browser.tabs.autoHide)?
Also note that bug 456535 is fixed on trunk. But hiding the menu bar by default would be a usability loss unless the most important actions are available as a toolbar button (à la IE8, Chrome, Safari).
Assignee: nobody → paul
Whiteboard: [nv]
(In reply to comment #2)
> How about hiding the tab bar when there's only one tab (browser.tabs.autoHide)?

I like this idea.

> Also note that bug 456535 is fixed on trunk. But hiding the menu bar by default
> would be a usability loss unless the most important actions are available as a
> toolbar button (à la IE8, Chrome, Safari).

Another good idea. I agree that if we do it we would want those things available via toolbar. I would think it might even be OK to have that button open a menu with all of those toolbar items instead of trying to pick the "important" menus.
Priority: -- → P2
Created attachment 386607 [details] [diff] [review]
Patch v0.2

Adds #ifdefs as appropriate (is there a preferred #ifdef vs #ifndef usage?)

* hides statusbar
* hides personal toolbar (bookmarks)
* uses small icons
* sets browser.tabs.autoHide to true
Attachment #384014 - Attachment is obsolete: true
Attachment #386607 - Flags: review?(vladimir)
Attachment #386607 - Flags: review?(vladimir) → review+
Created attachment 387565 [details] [diff] [review]
Patch v0.3

Adds throbber to navigator bar
Attachment #386607 - Attachment is obsolete: true
Attachment #387565 - Flags: review?(vladimir) → review+
pushed http://hg.mozilla.org/mozilla-central/rev/b24ba744b963

This is another case where we'll likely want some followup work done. But probably best done in another bug.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Created attachment 387748 [details] [diff] [review]
Patch v1.0 (as checked in)

The only difference was moving the throbber immediately after the search field so that it's in the right place when in fullscreen mode.
Attachment #387565 - Attachment is obsolete: true
Attachment #387748 - Flags: review+

Comment 8

9 years ago
Verified fix on Mozilla/5.0 (Windows; U; WindowsCE 6.0; en-US; rv:1.9.2a2pre)
Gecko/20090810 Minefield/3.6a2pre
*  hides statusbar
* hides personal toolbar (bookmarks)
* uses small icons
* sets browser.tabs.autoHide to true
* Throbber placed after the search bar
Status: RESOLVED → VERIFIED
Duplicate of this bug: 496848
You need to log in before you can comment on or make changes to this bug.