Closed Bug 499212 Opened 11 years ago Closed 10 years ago

panning the widgetstack should scroll the underlying content document

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 514623

People

(Reporter: Gavin, Unassigned)

Details

Attachments

(1 obsolete file)

This involves calling scrollTo() on the window when panning.
Attached patch patch (obsolete) — Splinter Review
We need to be careful about how this interacts with the patch in bug 452286. In particular, we could get into pan->scroll->pan->scroll loops. Right now this mostly works because eventually either the pan or the scroll will be a no-op and will therefore break the loop, but it might be a bit dangerous to rely on that (e.g. rounding errors might cause trouble).
Attachment #384007 - Attachment is obsolete: true
The patch in bug 401350 should fix this.
Sorry, meant bug 514623.
Depends on: 514623
let's just dupe this to bug 514623
No longer blocks: 479862
Status: NEW → RESOLVED
Closed: 10 years ago
No longer depends on: 514623
Resolution: --- → DUPLICATE
Duplicate of bug: 514623
Component: General → Panning/Zooming
You need to log in before you can comment on or make changes to this bug.