Having trouble recovering tabs message displayed when crash not caused by Firefox

RESOLVED DUPLICATE of bug 344852

Status

()

RESOLVED DUPLICATE of bug 344852
10 years ago
9 years ago

People

(Reporter: bugzilla1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [notacrash])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090615 Firefox/3.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090615 Firefox/3.5

OS X kernel panicked on me, and when I restarted Firefox, it gives me the following message:

"Well, this is embarrassing.

Firefox is having trouble recovering your windows and tabs. This is usually caused by a recently opened web page."

The problem is that the crash wasn't caused by Firefox, and there is nothing wrong with my windows and tabs.  I would expect to see this message only if Firefox tried to restore everything then crashed immediately.  I click restore, and everything restores with no trouble.  A message like this is better:
http://farm4.static.flickr.com/3037/3101288490_62e5c3a041_o.jpg

The error that is given implies that some tab caused the crash, no matter when the actual cause it, and says Firefox is having trouble restoring m session when it is not.

The message is accessible at about:sessionrestore if you want to see it without crashing Firefox.

Reproducible: Always

Updated

9 years ago
Component: General → Session Restore
QA Contact: general → session.restore
Whiteboard: [notacrash]

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 344852
You need to log in before you can comment on or make changes to this bug.