Cannot Install any Addons: Unexpected installation error -203

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: Jacobi, Unassigned)

Tracking

1.9.1 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090615 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090615 Firefox/3.5 (.NET CLR 3.5.30729)

You cannot use or install any addons for any of the firefox builds; the beta or 3.11. I have tried both to no success. Any addons i had in stalled are rendered useless; they say they're installed but they dont work (this goes for any themes as well).
This is the exact error that occurs when trying to install chromifox companion on 3.5RC

Firefox could not install the file at 

https://addons.mozilla.org/en-US/firefox/downloads/latest/10339/addon-10339-latest.xpi

because: Unexpected installation error
Review the Error Console log for more details.
-203

All other addons produce similar errors as well.

Reproducible: Always

Steps to Reproduce:
1.Open Firefox
Actual Results:  
No addons were displayed properly (themes etc.) Or a failed installation

Expected Results:  
Addons should do what they're designed to do or they should be installed without error.

Comment 1

9 years ago
See this page:
http://kb.mozillazine.org/Unable_to_install_themes_or_extensions_-_Firefox#Unexpected_installation_error_-203

Updated

6 years ago
Summary: Cannot Install any Addons → Cannot Install any Addons: Unexpected installation error -203
Version: unspecified → 3.5 Branch

Comment 2

6 years ago
[BUmping version - still in 3.6 according to duplicates]
Version: 3.5 Branch → 3.6 Branch

Updated

6 years ago
Duplicate of this bug: 638122

Updated

6 years ago
Duplicate of this bug: 618536
Component: Extension Compatibility → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: extension.compatibility → add-ons.manager
Version: 3.6 Branch → 1.9.1 Branch
Is this still a problem in more recent versions of Firefox?

Comment 6

6 years ago
(In reply to Dave Townsend (:Mossop) from comment #5)
> Is this still a problem in more recent versions of Firefox?

I haven't seen it in a long time.
Since we rewrote the entire add-ons manager and I don't think it is even physically possible to get such an error message any more I don't think we need to keep this bug open any longer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.