News Connection refused confuses Mozilla

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: azaroth, Assigned: mscott)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
When Mozilla is unable to connect to a news server via a link, it displays an
alert reading "Connection refused by server at news.netscape.com:119" and then
freezes.

I am inside a firewall system that doesn't allow for connections to off site
machines on port 119, the error is No Route to Host. Hence the steps to
reproduce are rather cumbersome.

Steps to Reproduce:

1)  Make port 119 unavailable, but the server machine available to ping etc
2)  Go to the URL http://www.mozillazine.org/talkback.html?article=1613
3)  Click on the (LINK) link in the comment titled Coinky-Dink

Debugging information:

Nothing is given, Mozilla just freezes. :(

 -- Azaroth
(Reporter)

Comment 1

18 years ago
I was mistaken. The problem is when you click the link /twice/, before the alert
has had a chance to show.  At which point the display hangs, but clicking Back
allows the alert from the second click to appear.

Steps to reproduce:
3)  Clink on the (LINK) link twice before the first alert shows

Anyone with X wanting to reproduce, talk to me on IRC and I'll throw a lizard to
your $DISPLAY.
 -- Azaroth
Component: Networking → Threading

Comment 2

18 years ago
I checked this on azaroths binary, as I can't block 119 on my machine.
It didn't hang, but it had some serious event trouble:
clicking twice on the link tries to open the article twice, giving two 
consecutive alert windows, the second one comes up after I ok'ed the first.
When trying to go back, I get another alert window. But the location remains.
When trying to go back the second time, I get another alert window, and then
the previous location is restalled.
Alert boxes always say: "The connection was refused when attempting to contact
news.mozilla.org:119"

Changed the summary to confuse instead of crash, but adding crash keyword.
The crash seems to be pretty dependent of timing.

Axel
Status: UNCONFIRMED → NEW
Component: Threading → Event Handling
Ever confirmed: true
Keywords: crash
Summary: News Connection refused crashes Mozilla → News Connection refused confuses Mozilla

Comment 3

18 years ago
->mscott
Assignee: gagan → mscott

Comment 4

18 years ago
I don't have a environment where I can block the news server.
However if I put in an invalid URL
news://neows.mozilla.org:11/39A2394B.E6D9F317@netscape.com 
then hit return in the URL bar I get a dialog and after I click ok on the dialog
the browser does not redraw and the URL bar does not recognize keystrokes.
However the menus and buttons work. If I press the back button the browser seems
to work normally after that. 

Comment 5

18 years ago
Reporter is this still occuring in the latest nightlies?
(Assignee)

Comment 6

18 years ago
I'm not crashing anymore. I'm going to mark this fixed so our QA can test it.
This bug belongs in mailnews so I'm going to reset the product too.
Component: Event Handling → Mail Back End
Product: Browser → MailNews
QA Contact: tever → esther
(Assignee)

Comment 7

18 years ago
this is working for me. 
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
QA Contact: esther → stephend
This is working for me, too (and Rob, whom I mailed privately).
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.