Message pane empty until restart after switching layouts (for feeds)

RESOLVED DUPLICATE of bug 531397

Status

RESOLVED DUPLICATE of bug 531397
10 years ago
5 years ago

People

(Reporter: rkent, Unassigned)

Tracking

({regression})

Trunk
regression
Bug Flags:
wanted-thunderbird +
blocking-thunderbird3 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Quite frequently when I switch layouts, say from "Classic" to "Wide" or from "Wide" to "Vertical", the message pane becomes blank, and remains blank until I restart Thunderbird. This is seen on a recent trunk custom release build. I notice this time the message from gloda "this should not be happening! arrgggggh!" though I cannot confirm that this always occur when when I see this issue.
(Reporter)

Comment 1

10 years ago
It happened again, while viewing newsgroups messages. No layout switch involved. All newsgroups were unviewable, but when I selected a local folder I could view messages, and after that the newsgroups were viewable again without restarting.
(In reply to comment #0)
> Quite frequently when I switch layouts, say from "Classic" to "Wide" or from
> "Wide" to "Vertical", the message pane becomes blank, and remains blank until I
> restart Thunderbird. This is seen on a recent trunk custom release build. I
> notice this time the message from gloda "this should not be happening!
> arrgggggh!" though I cannot confirm that this always occur when when I see this
> issue.

asuth, is the gloda message mentioned above familiar? Is it possibly related to the issue in any way?
This feels like it would be a very high visibility bug to new users of Thunderbird, so if this turns out to be at all reproducible, I think it has to block.
Flags: blocking-thunderbird3?
Keywords: regression
Seems WFM for me on linux.
(Reporter)

Comment 5

10 years ago
Here's reliable STR for me with RSS feeds:

1) start TB
2) select an RSS folder, and select a feed in the folder (feed displays in message pane)
3) using menu View/Layout, switch layouts (say from classic to wide)

Actual results: message pane is blank, and stays blank for any RSS feed selected in any folder until restart.

Expected results: RSS feed is visible in message pane.

In DOM inspector, whether the feed is visible or not, I can see all of the content available under the msgSummary DIV element. But nothing shows in the message pane on my screen - and the red border does not highlight when I click on that element (but it does when the feed is visible).

I guess I should try this with a clean profile, and official nightly build.
I see this too now, but only for feeds.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-thunderbird3? → blocking-thunderbird3+
OS: Windows XP → All
Hardware: x86 → All
Summary: Message pane empty until restart after switching layouts → Message pane empty until restart after switching layouts (for feeds)
With a small correction: it's only the current feed for me.
(Some extension, was causing other problems for feeds to show.)
The Thunderbird drivers wish to release Thunderbird 3 as soon as possible. As a
result, we feel that this bug shouldn't stand in the way of all the other good
work getting into the hands of users sooner rather than later. Therefore we are
retargeting it for 3.1. See http://ccgi.standard8.plus.com/blog/archives/242
for more details. The 3.1 release is expected to be a quick release soon after
Thunderbird 3.
Flags: blocking-thunderbird3.1+
Flags: blocking-thunderbird3-
Flags: blocking-thunderbird3+

Comment 9

9 years ago
This looks very like the problem I have been having in TB3 and have filed a separate Bug - no 542213.  In case it helps, I have ascertained that I have to have an RSS (News & Blogs) folder for this problem to occur (my current profile does not have an RSS folder and the problem has not occurred for well over a week now). And the problem is usually, but not always, triggered by replying to a post in a Usenet folder. After that, no message or email or RSS article can be displayed in the message pane or in a new tab, although they do display ok in a new window.   The sequence for the problem to occur is this :

 Steps to Reproduce:
1. Reply to a few emails, but don't need to send, just x out of these.
2. go into a News & Blogs (RSS) folder and display a few news feed items such as from BBC.
3. Go into a Usenet folder and display a couple of messages.  Reply to a
message (no need to actually send it).  
4. Usualls, although not always, now, click on any message or email or news
feed article in any folder, and the Message Pane will be blank.
Actual Results:  
Blank message pane.


NOTE that once the problem has occurred, the only way to get out of it is to restart TB.  Once the problem has occurred, if I select text from an email or Usenet post and press Reply, not just the selected text, but the entire original message is quoted in the reply - this is a definite link.

Hope the above is helpful.
I think it would be great to get this as soon as possible, but it doesn't feel like such a strong pain point that we'd block Tb 3.1 on it if it were the last bug standing.  Adding wanted-thunderbird+.
blocking-thunderbird3.1: --- → rc1+
Flags: blocking-thunderbird3.1+ → wanted-thunderbird+
I've just realised this is the same as bug 531397. As bug 531397 has more debugging information on, duping it forward.
Status: NEW → RESOLVED
blocking-thunderbird3.1: rc1+ → ---
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 531397

Comment 12

5 years ago
Unclear whether this bug is still active or is marked as a duplicate. There are MANY bugs concerning the message body pane being empty in various situations.

The problem described here is still present in TB 24.6.0. Thanks to this bug report, I learned that simply restarting TB restores correct behavior.
You need to log in before you can comment on or make changes to this bug.