If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

when marking as duplicate, check that the other bug is actually older than the current one

RESOLVED WONTFIX

Status

()

Bugzilla
Bugzilla-General
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: esigra, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5) KHTML/3.5.10 (like Gecko)
Build Identifier: 

When marking B as duplicate of A, check that A is actually older than B. If not, the user is probably about to make a mistake (confusing the 2 bug reports). Under some exceptional circumstances, it is maybe appropriate to mark an older bug as a duplicate of a newer. But then require a special field to be filled with an explanation of that circumstance.

(Some more rationale, in case someone did not get it yet: Marking a bug as a duplicate is like telling the reporter that he should have searched better before reporting. But if the bug report that his report is marked a duplicate of did not yet exist, there was no way that he could have found it.)

Reproducible: Always

Comment 1

8 years ago
That's not something we want to see implemented. There are different reasons why it makes sense to mark an older bug as a dupe of a newer one (better description, a long CC list, an already reviewed patch, etc...). A warning or something similar is in 99% of cases not desired.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.