Closed Bug 499492 Opened 12 years ago Closed 11 years ago

New separator at end of toolbar goes to end of bookmarks

Categories

(Firefox :: Toolbars and Customization, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 447571

People

(Reporter: 2pawnder, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090620 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090620 Minefield/3.6a1pre

If you have enough bookmarks in the bookmark toolbar that there are the two arrows ">>" on the far right of the toolbar, then if you right click to the left of it and try to add a new separator, the separator jumps to the end of the bookmarks (after the last bookmark in the list under the ">>").

Reproducible: Always

Steps to Reproduce:
1. Put enough bookmarks so that they don't all fit on the bookmark toolbar.
2. Right click to the left of the ">>" or "Show more bookmarks" button, but not so left that you right click on the actual bookmark there.
3. Click "New Separator". Now, when you click on the ">>" show more bookmarks button, you should see a long line, the separator, at the bottom of the list.
Actual Results:  
There was a separator at the end of the bookmark list.

Expected Results:  
It should have placed a separator directly before the first bookmark in the ">>" (Show more bookmarks) menu. Then, if you were to remove a visible bookmark (or two), the separator should have been between the previously last visible bookmark on the bar and the first one in the Show more bookmarks menu.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 447571
You need to log in before you can comment on or make changes to this bug.