If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

escape key should close saved passwords dialog

RESOLVED DUPLICATE of bug 668903

Status

()

Toolkit
Password Manager
--
trivial
RESOLVED DUPLICATE of bug 668903
8 years ago
3 years ago

People

(Reporter: u235898, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1pre) Gecko/20090620 Shiretoko/3.5pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1pre) Gecko/20090616 Lightning/1.0pre Shredder/3.0b3pre

some of the sub preference menus like "image exception", "popup exceptions" and "view my passwords" will not close on hitting ESCape key


Reproducible: Always

Steps to Reproduce:
1. open exception dialog in preference menu
2. hit ESCape
Actual Results:  
- none -

Expected Results:  
window get's closed
(Reporter)

Comment 1

8 years ago
(In reply to comment #0)
relates to Bug 414071

Comment 2

8 years ago
Can you list the dialogs that need this? Only the passwords one is relevant for tb (of the ones you mentioned).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

8 years ago
ok, then passwords one is the last one I can identify for that. Other ones are Firefox specific, you're right

Comment 4

8 years ago
This is actually shared (toolkit) code - passwordManagerExceptions.xul

I wonder if it not getting auto closed is caused by the search field, esc simply clears that.
Component: Preferences → Password Manager
Product: Thunderbird → Toolkit
QA Contact: preferences → password.manager
Summary: let escape key close sub-preference dialogs (e.g. exception and saved passwords dialog) → escape key should close saved passwords dialog
Fixed in bug 668903
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 668903
You need to log in before you can comment on or make changes to this bug.