Mozilla Tri-License Not Offered For Addons

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
--
enhancement
RESOLVED WONTFIX
9 years ago
2 years ago

People

(Reporter: Stephen Augenstein, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090619 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090619 Minefield/3.6a1pre

Extensions must now include a license with each version, but the Mozilla Tri-License, a very popular license type, is not offered in the drop down. It would make it a lot easier for developers if they didn't have to put it in the "Other" option.

Reproducible: Always
Created attachment 384415 [details]
Screenshot showing MPL on AMO
Nevermind, that's MPL not tri-license.  :)
I thought this was left out on purpose but I wasn't in on the details.  CCing people who were

Comment 4

9 years ago
the importance of this bug should be more than just "enhancement", perhaps "minor", all mozilla code is tri-licensed, the extensions on AMO should have the possibility to use this option easily as well.

Comment 5

9 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
I can't find the other bug, but this is a dupe of a wontfix.  There is an "other" field which can be used for this.  We didn't want to add this because it's actually 3 licenses that we'd have to list on the page (with links to each) which is a special case.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.