Application update should apply while running/without progress meter

RESOLVED DUPLICATE of bug 307181

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 307181
9 years ago
8 years ago

People

(Reporter: Joe Drew (not getting mail), Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

(Reporter)

Description

9 years ago
Updating apps on startup really sucks. If I have to wait for updates when I just want to launch my browser, I get frustrated, and sometimes I even forget that I'm trying to launch Firefox when it takes a while.

Instead of applying on startup, we should find some way of applying while the app is still running, and then doing some O(1) stuff on shutdown or startup (for example, renaming app-new.exe to app.exe).
This simply must be a dupe.

Of course this is desired, and if it were trivial we'd have done it before. (Right now this is kind of a basic RFE, as well I'd like to see more of a set of suggestions around how we'd actually do this.)

The experience should be (I'm really, really sure I've written this before):

 - download comes in the background
 - we apply it
 - if the user hasn't restarted in 24 hours, we show a small indication asking them to do so
Whiteboard: [dupeme]
I suspect it is a dupe but I haven't checked yet.

Also, I've been considering how we could apply the update on exit but if we start using MSI's the update process will need to change significantly for Windows so I haven't been spending many cycles on update yet.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 307181
You need to log in before you can comment on or make changes to this bug.