Closed Bug 499796 Opened 10 years ago Closed 10 years ago

Crash nsFocusManager::SetFocusInner()

Categories

(Core :: User events and focus handling, defect, major)

x86
Windows Mobile 6 Professional
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 497934
Tracking Status
fennec 1.0a2-wm+ ---

People

(Reporter: pavlov, Unassigned)

Details

On Windows Mobile, just dragging around the Fennec window I'm crashing here pretty frequently.  The params aren't valid as this is as opt/symbols build.

>	xul.dll!nsFocusManager::SetFocusInner(nsIContent* aNewContent = 0xffffffff, int aFlags = 7, int aFocusChanged = 7) Line: 988, Byte Offsets: 0x230	C++
 	xul.dll!nsFocusManager::SetFocusedWindow(nsIDOMWindow* aWindowToFocus = 0xffffffff) Line: 350, Byte Offsets: 0xac	C++
 	xul.dll!nsEventStateManager::PostHandleEvent(nsPresContext* aPresContext = 0xffffffff, nsEvent* aEvent = 0x00000007, nsIFrame* aTargetFrame = 0x00000007, nsEventStatus* aStatus = 0x2dbbe4a4, nsIView* aView = 0x6577fac0) Line: 2649, Byte Offsets: 0x590	C++
 	xul.dll!PresShell::HandleEventInternal(nsEvent* aEvent = 0xffffffff, nsIView* aView = 0x00000007, nsEventStatus* aStatus = 0x00000007) Line: 6307, Byte Offsets: 0x330	C++
 	xul.dll!PresShell::HandlePositionedEvent(nsIView* aView = 0xffffffff, nsIFrame* aTargetFrame = 0x00000007, nsGUIEvent* aEvent = 0x00000007, nsEventStatus* aEventStatus = 0x2dbbe4a4) Line: 6179, Byte Offsets: 0x1c0	C++
 	xul.dll!PresShell::HandleEvent(nsIView* aView = 0xffffffff, nsGUIEvent* aEvent = 0x00000007, nsEventStatus* aEventStatus = 0x00000007) Line: 6043, Byte Offsets: 0x758	C++
 	xul.dll!nsViewManager::DispatchEvent(nsGUIEvent* aEvent = 0xffffffff, nsEventStatus* aStatus = 0x00000007) Line: 1246, Byte Offsets: 0xac4	C++
 	xul.dll!HandleEvent(nsGUIEvent* aEvent = 0x00000000) Line: 169, Byte Offsets: 0xbc	C++
 	xul.dll!nsWindow::DispatchEvent(nsGUIEvent* event = 0xffffffff, nsEventStatus& aStatus = 0) Line: 981, Byte Offsets: 0x4c	C++
 	xul.dll!nsDOMWindowUtils::SendMouseEvent(nsAString_internal& aType = {...}, float aX = 0.0, float aY = 1.401e-045#DEN, int aButton = 7, int aClickCount = 7, int aModifiers = 0, int aIgnoreRootScrollFrame = 1) Line: 266, Byte Offsets: 0x290	C++
 	asmXPTC_InvokeByIndex
tracking-fennec: --- → 1.0a2-wm+
Looks like bug 497934 to me.
Looks like it to me too, resolving as a duplicate
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 497934
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.