Closed Bug 499835 Opened 11 years ago Closed 11 years ago

IPv6 addresses: scope identifier is transmitted in the Host: header

Categories

(Firefox :: General, defect, major)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 464162

People

(Reporter: michael+moz, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.7) Gecko/2009030810 Iceweasel/3.0.9 (Debian-3.0.9-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.7) Gecko/2009030810 Iceweasel/3.0.9 (Debian-3.0.9-1)

When using an URL like described (link local address plus scope identifier), Firefox does not strip the scope identifier (%eth0) from the Host: header, thus generating a Bad Request on server side (tested with Apache 2.2.11 and lighttpd 1.4.19).

You need the scope identifier to tell an application to which interface the given link local address belongs. If leaving it out entirely, firefox can’t connect either (which is not a bug, I just wanted to explain why I need the scope identfier in the first place).

I’m filing this bug as major because it restricts me from accessing local websites AT ALL and it violates the RFCs.

Reproducible: Always
RFC is the following:

|                Hence, the format MUST be used only within a
| node and MUST NOT be sent on the wire unless every node that
| interprets the format agrees on the semantics.
 -- RFC 4007, section 11.2

I also noticed bugreport #464162. Is my version of Firefox too old to contain the fix or did this break again in the meantime?
According to that report, this is fixed in Firefox 3.5.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 464162
You need to log in before you can comment on or make changes to this bug.