Camino will not load sites that start with http://, only pages that start with https:

VERIFIED INVALID

Status

Camino Graveyard
General
--
major
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: Mike, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20

When using Camino pages will not load. I get the error message Proxy Server Refused Connection

      

      
      
      

      
        
        

          

The connection was refused when attempting to contact the proxy server you have configured. Please check your proxy settings and try again.


This happens on any unsecure site, but Firefox will load them.

Reproducible: Always

Steps to Reproduce:
1. OpenCamino
2. go to http://www.google.com/ -- or any other site starting with http://
3. get error message
Actual Results:  
got error message above 

Expected Results:  
page load

Pages load on same computer on same network with Firefox.

Typing build:config yields

about:buildconfig

Build platform
target
powerpc-apple-darwin8.10.2

Build tools
Compiler 	Version 	Compiler flags
gcc-4.0 -arch ppc 	gcc version 4.0.1 (Apple Computer, Inc. build 5370) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -isysroot /Developer/SDKs/MacOSX10.3.9.sdk -fpascal-strings -no-cpp-precomp -fno-common -I/Developer/SDKs/MacOSX10.3.9.sdk/Developer/Headers/FlatCarbon
g++-4.0 -arch ppc 	gcc version 4.0.1 (Apple Computer, Inc. build 5370) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -isysroot /Developer/SDKs/MacOSX10.3.9.sdk -fpascal-strings -no-cpp-precomp -fno-common -fshort-wchar -I/Developer/SDKs/MacOSX10.3.9.sdk/Developer/Headers/FlatCarbon

Configure arguments
--target=powerpc-apple-darwin8.10.2 --with-macos-sdk=/Developer/SDKs/MacOSX10.2.8.sdk --enable-application=macbrowser --enable-default-toolkit=cocoa --disable-tests --disable-accessibility --disable-jsd --enable-single-profile --disable-profilesharing --enable-canvas --enable-svg --disable-xpcom-obsolete --disable-xpinstall --with-macos-sdk=/Developer/SDKs/MacOSX10.4u.sdk --enable-macos-target=10.4 --with-macos-sdk=/Developer/SDKs/MacOSX10.3.9.sdk --enable-macos-target=10.3 '--enable-optimize=-g -O2' --disable-shared --enable-static
Build platform
target
i386-apple-darwin8.10.2

Build tools
Compiler 	Version 	Compiler flags
gcc-4.0 -arch i386 	gcc version 4.0.1 (Apple Computer, Inc. build 5370) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fpascal-strings -no-cpp-precomp -fno-common -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon
g++-4.0 -arch i386 	gcc version 4.0.1 (Apple Computer, Inc. build 5370) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fpascal-strings -no-cpp-precomp -fno-common -fshort-wchar -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon

Configure arguments
--target=i386-apple-darwin8.10.2 --with-macos-sdk=/Developer/SDKs/MacOSX10.4u.sdk --enable-application=macbrowser --enable-default-toolkit=cocoa --disable-tests --disable-accessibility --disable-jsd --enable-single-profile --disable-profilesharing --enable-canvas --enable-svg --disable-xpcom-obsolete --disable-xpinstall --with-macos-sdk=/Developer/SDKs/MacOSX10.4u.sdk --enable-macos-target=10.4 '--enable-optimize=-g -O2' --disable-shared --enable-static
This sounds like a bug in your proxy server.  Do you have proxies set up in the Mac OS X System Preferences?

Also, what version of Camino are you using?  about:buildconfig does not supply useful information, so it's always best to file the bug with the copy of Camino that's affected, when at all possible.

Comment 2

9 years ago
(In reply to comment #0)
> This happens on any unsecure site, but Firefox will load them.

Does Safari? Firefox doesn't use the OS proxy settings like Safari and Camino do.
(Reporter)

Comment 3

9 years ago
Neither Safari (v 1.3 ?) or Camino will load unsecure site.
But Firefox (I think it is 2.20.0) loads them.

I have stopped using Safari as I need to upgrade my OS in order to get the latest version.
Summary: Camino will not load sites that start with http://, olny pages that start with https: → Camino will not load sites that start with http://, only pages that start with https:

Comment 4

9 years ago
If Safari can't load them either, then you have proxy issues (either a bad proxy set in the OS settings, or not having a proxy set for the OS that you need, and have set up in Firefox).

Closing INVALID since this isn't a Camino bug; if you need help fixing your proxy settings try the Camino forums or the Apple discussion groups.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.