several typing characters print in error,

RESOLVED WORKSFORME

Status

Camino Graveyard
General
--
trivial
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: naturalhealth4u, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.21) Gecko/20090327 Camino/1.6.7 (MultiLang) (like Firefox/2.0.0.21pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.21) Gecko/20090327 Camino/1.6.7 (MultiLang) (like Firefox/2.0.0.21pre)

i.e. apostrophes, come out looking like a capitol i rather than an  apostrophe.  i would give an example but need a different font to type the "i" it looks like.  one with a bar at the top and bottom is what i mean.  

dashes also come out strange. they resemble little slanted slashes in a row, rather than a simple dash.   and there is another problem where a small elevated  v shaped figure replaces a hyphen .   i'm not sure if there are others or not. this is all i recall at the moment. 

Reproducible: Always

Steps to Reproduce:
1.  all i have to do is open any web site.  the typing has the problems described above.  i have been to many sites and it still happens.   
2.
3.
Actual Results:  
it's not a serious problem, it's just a little annoying and i'm sure a programming problem somewhere that i though would be good to have cleared up. the problem has been here since for some time and i thought it would be automatically corrected as i thought there would be others who had the problem but it hasn't so i'm reporting it now.  

Expected Results:  
i expect that the programming problem will be corrected somehow. i love the browser, have lots of book marks , with folders etc. and would not want to change browsers. 

theme doesn't seem to be a problem, it is just any typing on any site i open.

Comment 1

9 years ago
What are your font settings in the Appearance pane of Camino's preferences?
(Reporter)

Updated

9 years ago
Keywords: 4xp
Whiteboard: fonts are western

Comment 2

9 years ago
Please don't mess with tags and whiteboard values.

We need the specific font settings you are using, since this sounds like a font problem.
Keywords: 4xp
Whiteboard: fonts are western
(Reporter)

Updated

9 years ago
Summary: several typing characters print in error, → several typing characters print in error, it is not clear where i am to add requested info my fonts info is: proportional (serif) , osaka 10 pt. monospace 10pt. i often enlarge type
(Reporter)

Comment 3

9 years ago
ok, i am sorry i didn't scroll down far enough to find the spot to type new information.  when i saw the first commit button, i thought that was the end.  so  i wrote in the white board spot.  

 my font info is: proportional (serif) , osaka 10 pt.   monospace 10 pt. 

i often enlarge type for clarity. 

thank you.
Summary: several typing characters print in error, it is not clear where i am to add requested info my fonts info is: proportional (serif) , osaka 10 pt. monospace 10pt. i often enlarge type → several typing characters print in error,
This seems to be a combination of setting a Japanese font (Osaka) for your Western font, checking "Always use my fonts" and bugs in dealing with certain glyphs in certain fonts in the version of Gecko that ships with Camino 1.6.x.

This all works OK in Camino 2.0b3, so it was fixed by the graphics rewrite.

You have a couple of options:

1) Don't set your Western fonts to Osaka

2) Don't check "Always use my fonts" (though this will only un-break some sites)

1a/2a) Press the "Reset" button in the Fonts tab of the Appearance preferences to reset all of your font preferences to the defaults

3) Keep your current settings and upgrade to Camino 2.0b3 if you have at least Mac OS X 10.4 (this will irrevocably migrate some files in your profile, so you should make a backup copy if you go that route)

Closing WFM since this works in 2.0b3 and I don't want to hunt for the Cairo font rewrite bug to dupe against.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.