The Title Bar does not show the TAMIL font correctly

RESOLVED DUPLICATE of bug 373398

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 373398
9 years ago
9 years ago

People

(Reporter: Izhanthiraiyan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727; MS-RTC LM 8; MS-RTC LM 8)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

The Title Bar does not show the TAMIL font correctly. It shows something like boxes instead of the actual TAMIL font.

Reproducible: Always

Steps to Reproduce:
1.Open the firefox version 3.0.5
2.Enter the following address in the URL address bar.
3.http://thamizhinimai.blogspot.com/
4.Press enter.
5.Check out the title bar of the firefox
Actual Results:  
The Title bar of the firefox does not display the TAMIL font properly. It is being displayed as boxes.

Expected Results:  
The Title bar of the firefox should display the TAMIL font properly.

Comment 1

9 years ago
That's normal actually - the window title is displayed by the operating system,
which take the characters from a single font (which one depends on the windows
theme, and can be customized). Note that the same problem will happen in
Internet Explorer. 

First of all, that font needs to contain that particular character. But most
fonts are not suitable as "universal" unicode fonts. Second, Firefox has a more
sophisticated algorithm, where characters from different fonts are combined
into a single set. Not perfect either (characters aren't always at the same
size), but that's why page-content and tabs look a lot better.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373398

Comment 2

9 years ago
oops, the comment is slightly incorrect (copied form another bug, which was more complicated)

The real problem is that the operating system is drawing the title bar, and it can't draw a Tamil text because the necessary characters are missing from the system font. Note that Internet Explorer has the same error !
(Reporter)

Comment 3

9 years ago
The problem was resolved after installing the East Asian Language pack.
You need to log in before you can comment on or make changes to this bug.