Options to make Thunderbird the default mail and newsreader cannot be ticked off

RESOLVED INVALID

Status

RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: mikkel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1 GTB5 (.NET CLR 3.5.30729)
Build Identifier: 2.0.0.22 (20090605)

In the prompt window that asks if I would like to make Thunderbird the default e-mail, newsreader and RSS feed application, the tickboxes next to the three options cannot be ticked off - I click them, but nothing happens.

The problem is the same whether I am prompted automatically (e.g. after an upgrade), or if I invoke the prompt via Tools > Options > Check Now.

The only way I can make it my default e-mail client is to use Windows XP's built-in tool for setting default applications.

Reproducible: Always

Steps to Reproduce:
1. Open menu Tools
2. Select Options
3. Click on Check Now in the General tab
Actual Results:  
The tickboces in the pop-up window cannot be ticked off - and Thunderbird is not set as the default client.

Expected Results:  
The boxes should get a tick when I click them, and when I click OK, Thunderbird should be registered as the default mail/news/RSS feed client.

The problem has also been there in earlier versions.
(Reporter)

Comment 1

9 years ago
Created attachment 384590 [details]
Screenshot of the alert box (in Danish)

Notice that the checkboxes look a little odd - as if they have a little border around them. To me they look "broken".
Confirmed here on 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090622 Lightning/1.0pre Shredder/3.0b3pre ID:20090622031432

But I'm not sure that is an error... cold be deliberate, because only from other email-client you can set "others" client as default mail -client.
Bryan is this "by design" ?
This sounds like a bug, at least I don't think this is by design.  Adding sid since he knows this code.
Mikkel: could you try using a Shredder nightly and seeing what options you get?

By "ticked off", do you mean going from checked to unchecked or from unchecked to checked? The first one's by design, of course (what would be the default client then?) while the second one would be a bug.

Note that on 3.0, the RSS feeds checkbox is disabled due to bug 445823. News and email should work, though.

Oh, and could you please upload a screenshot using the default theme? I think I understand the state of the checkboxes, but it'd be great if I could be sure about it.
(Reporter)

Comment 6

9 years ago
Created attachment 384725 [details]
Screenshot of the alert box with default theme selected (in Danish)

Everything works fine here!
(Reporter)

Comment 7

9 years ago
(In reply to comment #5)
> Mikkel: could you try using a Shredder nightly and seeing what options you get?

I don't think that will be necessary - I just switched to the default theme to make the screenshot you requested, and everything works fine there!

So, it would appear that this is a bug in the theme that I was using before ("Modern Modoki 2.03").

Anyway, let me just answer your other questions:

> By "ticked off", do you mean going from checked to unchecked or from unchecked
> to checked?

The latter. "Ticked off" means it gets a tick inside the square.

> Note that on 3.0, the RSS feeds checkbox is disabled due to bug 445823. News
> and email should work, though.

As you can see from the new screendump, only e-mail is active by me. Both news and RSS are greyed out.

> Oh, and could you please upload a screenshot using the default theme?

Done!
(In reply to comment #7)
> So, it would appear that this is a bug in the theme that I was using before
> ("Modern Modoki 2.03").

OK, good to know, and thanks for the screenshot. Seems like the theme doesn't have an image for a disabled and checked checkbox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(In reply to comment #7)
> As you can see from the new screendump, only e-mail is active by me. Both news
> and RSS are greyed out.

Yeah it's a one-way street ;)
The backend doesn't have support for un-setting as default IIRC.
You need to log in before you can comment on or make changes to this bug.