If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Dragging a tab to open a new window makes shutting that window impossible

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: gaby2300, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-AR; rv:1.9.1) Gecko/20090616 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-AR; rv:1.9.1) Gecko/20090616 Firefox/3.5

I cannot close the first two windows without closing the browser. Should I close the browser, when I restart it, I get the same three windows opened and the same issue as before
I cannot close the browser clicking on the red cross over the upper right corner, only by File>Exit.

Or to force the browser to close by Ctrl+Alt+Del, Aplications, selecting one of the extra windows (not the browser’s one), clicking Finish task. Then all the windows get closed including the browser’s one and when I restart the browser I get the “This is a shame” message within the restore session window, then I select “Start a new session” and then and only then I have a normal browser window.

Lo and behold I try to tear of a tag to open in a new window, or I right click on a tag and choose Open in a new window from the context menu, I have the same issue all over again!

So in my case, the tag tear off doesn’t work AT ALL!!!

 The only way to solve this for once and for ever is by creating a new profile, but even this doesn’t always work.


Reproducible: Always

Steps to Reproduce:
1.Open FF 3.5 RC2
2.Drag a tab off the browser to create a new window.
3.The new window cannot be closed,nor the original one.
Actual Results:  
I have to force the browser to close by Ctrl+Alt+Del, Aplications, selecting one of the extra windows (not the browser’s one), clicking Finish task. Then all the windows get closed including the browser’s one and when I restart the browser I get the “This is a shame” message within the restore session window, then I select “Start a new session” and then and only then I have a normal browser window, except I cannot close the browser clicking on the red cross over the upper right corner, only by File>Exit.

Lo and behold I try to tear of a tag to open in a new window, or I right click on a tag and choose Open in a new window from the context menu, I have the same issue all over again!


Expected Results:  
The browser should close by clicking on the red cross over the upper right corner, and by File>Exit.
Tearing off a tab should open a new window but I should be able to shut this window either by clicking on the red cross over the upper right corner, or by File>Exit.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1pre) Gecko/20090622 Shiretoko/3.5pre

This works fine for me. Please retest in safe-mode, and if it also happens in safe-mode, try creating a new profile:
http://support.mozilla.com/en-US/kb/Safe+Mode
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Version: unspecified → 3.5 Branch
(Reporter)

Comment 2

8 years ago
Created attachment 384702 [details]
It's a screenshot showing the window's issue and some text explaining the screenshot
(Reporter)

Comment 3

8 years ago
The issue does not repeat it self in a new profile nor in the safe mode.
But I cannot go on creating new profiles each time I have an issue and I cannot use safe mode because I need some extensions to be able to work online.
Please DO solve this issue!!!
If the problem doesn't occur in safe-mode then it is most likely caused by an add-on. Please try to find out what add-on is causing this (by disabling them one by one) and notify the author so he can make his add-on compatible with the coming Firefox 3.5.
(Reporter)

Comment 5

8 years ago
I'll have to test 24 addons!!! And thankfully only one theme! I'll try to do it as soon as I can. I really want FF3.5 working without a single glitch because I really think it's the best browser ever.
(Reporter)

Comment 6

8 years ago
(In reply to comment #4)
> If the problem doesn't occur in safe-mode then it is most likely caused by an
> add-on. Please try to find out what add-on is causing this (by disabling them
> one by one) and notify the author so he can make his add-on compatible with the
> coming Firefox 3.5.

Thankfully I tested only the last few addons I had installed (all translation related) and I rapidly found the culprit.
I really want to thank Ria Klaassen for her ideas!
I've fully recovered FF 3.5 RC2's performance now and I'm very grateful for it!
Great that it's solved! Resolving Worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

8 years ago
(In reply to comment #7)
> Great that it's solved! Resolving Worksforme.

Many thanks for having helped me to solve the issue!
you're welcome :)
You need to log in before you can comment on or make changes to this bug.